Opened 10 years ago

Closed 10 years ago

#4030 closed bug (fixed)

Regression: booting on 64MB causes 'Out of memory'-errors

Reported by: idefix Owned by: axeld
Priority: critical Milestone: R1/alpha1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Somewhere between hrev30946 and hrev31054, a change has caused my computer to not fully booting Haiku anymore. There are a lot of 'Out of memory'-errors in the hrev31054 seriallog, while there are none in the log from hrev30946. See attached seriallogs.

Unfortunately I can't test any releases in between, as there weren't any images generated.

The computer has a Celeron@433MHz processor, 64MB memory and 440LX chipset.

Attachments (3)

seriallog booting r30946.txt (47.2 KB ) - added by idefix 10 years ago.
Seriallog of hrev30946 successfully booting.
seriallog booting r31054 v1.txt (46.8 KB ) - added by idefix 10 years ago.
Seriallog of hrev31054 showing 'Out of memory'-errors (beginning with '0x8106ca2c->VMAnonymousCache::_Commit(716800): Failed to reserve 716800 bytes of RAM').
seriallog booting r31054 v2.txt (51.9 KB ) - added by idefix 10 years ago.
Seriallog of hrev31054 showing 'Out of memory'-errors (beginning with 'vm_page_fault: vm_soft_fault returned error 'Out of memory' on fault at 0x700c06cc, ip 0x102811, write 1, user 1, thread 0x52').

Download all attachments as: .zip

Change History (8)

by idefix, 10 years ago

Seriallog of hrev30946 successfully booting.

by idefix, 10 years ago

Seriallog of hrev31054 showing 'Out of memory'-errors (beginning with '0x8106ca2c->VMAnonymousCache::_Commit(716800): Failed to reserve 716800 bytes of RAM').

by idefix, 10 years ago

Seriallog of hrev31054 showing 'Out of memory'-errors (beginning with 'vm_page_fault: vm_soft_fault returned error 'Out of memory' on fault at 0x700c06cc, ip 0x102811, write 1, user 1, thread 0x52').

comment:1 by idefix, 10 years ago

Please ignore 'seriallog booting hrev31054 v2.2.txt', it's the same as 'seriallog booting hrev31054 v2.txt'.

in reply to:  1 comment:2 by mmadia, 10 years ago

Replying to idefix:

Please ignore 'seriallog booting hrev31054 v2.2.txt', it's the same as 'seriallog booting hrev31054 v2.txt'.

deleted the attachment 'seriallog booting hrev31054 v2.2.txt'

comment:3 by anevilyak, 10 years ago

Milestone: R1R1/alpha1
Priority: normalcritical

This appears to be because some change or other (not sure which yet) broke/disabled swap support. Both Ingo and I noticed neither of our systems has any swap, though we did nothing to explicitly disable it.

comment:4 by anevilyak, 10 years ago

From a quick look, hrev30975 seems the only likely culprit in that range.

comment:5 by anevilyak, 10 years ago

Resolution: fixed
Status: newclosed

Should be fixed in hrev31098. Thanks Axel!

Note: See TracTickets for help on using tickets.