Opened 10 years ago

Closed 10 years ago

#4035 closed bug (fixed)

Missing symbol in GCC4/2 Hybrid

Reported by: jprostko Owned by: bonefish
Priority: normal Milestone: R1
Component: Build System Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

As noted by Humdinger on the Haiku Development list, there is an issue with some GCC2 apps such as Beam, BePDF, and VLC getting a "Missing symbol: gxx_personality_v0" error upon loading in a GCC4/2 hybrid environment.

I narrowed down the problem to hrev31110. Attached is a patch that addresses the issues on my end, although I don't think it's the way to handle the problem, since I kind of just went for the "try to get it working with the least amount of effort" approach. Naturally, reverting HaikuImage to 30109 would make things happy too, although counteract its whole intent, I suppose.

I initally thought the problem was only an issue with the libnet.so symlink, but I noticed the Beam error was actually due to an issue with libnetapi.so, so I addressed that as well in the patch.

I want to take a closer look at things later, but I think I'll head to sleep. In any case, I figured I'd submit a ticket with the patch just to give an idea where the issues lie. I kind of need to take a look at ImageRules and do some more builds to figure out more how all of these pieces fit together (like the use/non-use of "true") in rules such as the ones being used.

Attachments (1)

HaikuImage.diff (789 bytes) - added by jprostko 10 years ago.
HaikuImage patch to give an idea of the issue at hand

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by jprostko

Attachment: HaikuImage.diff added

HaikuImage patch to give an idea of the issue at hand

comment:1 Changed 10 years ago by bonefish

Status: newassigned

Looking into it.

comment:2 Changed 10 years ago by bonefish

Fixed in hrev31150.

comment:3 Changed 10 years ago by bonefish

Resolution: fixed
Status: assignedclosed

comment:4 Changed 10 years ago by humdinger

Resolution: fixed
Status: closedreopened

With hrev31152 I now have this error when launching e.g. BePDF: "Missing libraries: libstdc++.hrev4.so"

I hope this justifies reopening the bug.

Thanks to everybody looking into this!

comment:5 Changed 10 years ago by jprostko

Well, I can confirm that there isn't an libstdc++.hrev4.so present at all, which makes it kind of hard to find. ;) I'm using hrev31158. The plus side of this is that this made an unrelated bug evident to me, which I'll post a ticket about later when I get a chance.

comment:6 Changed 10 years ago by jprostko

This bug can be closed again, as it was resolved in 31159.

comment:7 Changed 10 years ago by axeld

Resolution: fixed
Status: reopenedclosed

Thanks for the note!

Note: See TracTickets for help on using tickets.