Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#4038 closed bug (duplicate)

Tracker random crash (GCC4 - r31165)

Reported by: miqlas Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: #3710 Blocking:
Has a Patch: no Platform: x86

Description

Sometimes if i try to drag the selected path from an Tracker window to the Terminal the Tracker crashing randomly. I have official GCC4 Haiku hrev31165 build.

(gdb) bt
#0  0x003bbe64 in BString::BString () from /boot/system/lib/libbe.so
#1  0x005b0977 in BPrivate::BColumnTitle::Draw ()
   from /boot/system/lib/libtracker.so
#2  0x005b1898 in BPrivate::BTitleView::Draw ()
   from /boot/system/lib/libtracker.so
#3  0x005b27d8 in BPrivate::BTitleView::Draw ()
   from /boot/system/lib/libtracker.so
#4  0x003660d6 in BView::_Draw () from /boot/system/lib/libbe.so
#5  0x0036f880 in BWindow::DispatchMessage () from /boot/system/lib/libbe.so
#6  0x0036fc80 in BWindow::UpdateIfNeeded () from /boot/system/lib/libbe.so
#7  0x0058a26b in BPrivate::BPoseView::WaitForMouseUpOrDrag ()
   from /boot/system/lib/libtracker.so
#8  0x0058a5c2 in BPrivate::BPoseView::MouseDown ()
   from /boot/system/lib/libtracker.so
#9  0x0036f23f in BWindow::DispatchMessage () from /boot/system/lib/libbe.so
#10 0x0036bd55 in BWindow::task_looper () from /boot/system/lib/libbe.so
#11 0x002bfd84 in BLooper::_task0_ () from /boot/system/lib/libbe.so
#12 0x00639b75 in thread_entry () from /boot/system/lib/libroot.so
#13 0x7003ffec in ?? ()
(gdb)

Change History (2)

comment:1 by mmlr, 11 years ago

Blocked By: 3710 added
Resolution: duplicate
Status: newclosed

Duplicate of #3710.

comment:2 by aldeck, 11 years ago

miqlas: Could you give more details in #3710. Thanks :)

Note: See TracTickets for help on using tickets.