Opened 10 years ago

Closed 10 years ago

#4037 closed bug (fixed)

Tracker crash post-initialization

Reported by: dvh Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Sometimes immediately, sometimes with some coaxing, browsing directories with Tracker on a gcc4-hrev31095 build results in Tracker crash to gdb, under the following conditions:

1) Running Haiku from a nightly test image as primary master, under VirtualBox 2.2.4, either Ubuntu Jaunty or Windows XP Hosts. 2) Primary slave is mapped to a partition on disk 3) Partition is initialized to BFS block size 2048 using DiskSetup 4) Files from the disk image are copied to the host partition using cp -rf, rather than using Tracker

Copying the contents of the system disk image to the host partition using Tracker preserves metadata and does not cause crashes during directory browsing.

Attachments (2)

gdb-tracker-r31095.txt (1.4 KB) - added by dvh 10 years ago.
gdb backtrace
syslog-tracker-r31095.txt (1.7 KB) - added by dvh 10 years ago.
syslog

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by dvh

Attachment: gdb-tracker-r31095.txt added

gdb backtrace

Changed 10 years ago by dvh

Attachment: syslog-tracker-r31095.txt added

syslog

comment:1 Changed 10 years ago by dvh

There's chatter on-list about the question but I'm open to assistance with additional investigation into the state of the filesystem. This isn't fully isolated and it's difficult to reproduce.

Also: is there an equivalent to dmidecode for use in bug reporting with haiku?

comment:2 Changed 10 years ago by axeld

Component: File Systems/BFSApplications/Tracker

comment:3 Changed 10 years ago by axeld

Resolution: fixed
Status: newclosed

It looks like something might be wrong with your MIME database, BContainerWindow::AddMimeMenu() did not check whether or not the MIME type was valid, and there was at least one invocation where this was not checked either.

In any case, the MIME type could become messed up if you build Haiku under Linux without using xattr support (but there is already a ticket for that somewhere).

The crash itself should be fixed in hrev31777.

Note: See TracTickets for help on using tickets.