Opened 10 years ago

Closed 9 years ago

#4054 closed bug (fixed)

Trac does not handle gzipped text attachments properly

Reported by: mmadia Owned by: axeld
Priority: normal Milestone: R1
Component: Website/Trac Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev31232-gcc2
gunzip does not properly extract it's contents. It appears to simply remove the extension.
Tested with ticket/4005/build_jam_j4_0.txt.gz

The above gz file was confirmed working with FreeBSD gzip 20070711

Change History (5)

comment:1 Changed 10 years ago by mmadia

Resolution: invalid
Status: newclosed

Turns out, this is an issue in Trac. For more information, see: http://dev.haiku-os.org/ticket/4005#comment:7

comment:2 Changed 10 years ago by meianoite

As mentioned on http://dev.haiku-os.org/ticket/4005#comment:11, the "gzipped" file that Trac gave me was a XHTML file with the contents of the gzipped file interspersed with the table Trac generates to syntax-highlight and linenumber source code files. In other words, it was totally garbled beyond recovery, as it probably interpreted some bytes as UTF or what have you and modified the resulting encoding.

Downloading the raw-attachment gave me something I had to gunzip *twice* in order to produce the original file.

comment:3 Changed 10 years ago by axeld

Component: Applications/Command Line ToolsWebsite/Trac
Resolution: invalid
Status: closedreopened

comment:4 Changed 9 years ago by mmadia

Summary: gunzip : does not work as expectedTrac does not handle gzipped text attachments properly

comment:5 Changed 9 years ago by mmadia

Resolution: fixed
Status: reopenedclosed

Seems to be working properly. http://dev.haiku-os.org/raw-attachment/ticket/4005/build_jam_j4_2.txt.gz expands properly. I'm assuming this was fixed when Trac was updated to 0.11.5 during the migration.

Note: See TracTickets for help on using tickets.