Opened 10 years ago

Closed 9 years ago

#4072 closed bug (fixed)

HDA audio sounds worse

Reported by: jahaiku Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Audio/HDA Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is a gcc4 build of hrev31391 on EeePC 4G.
I have attached output of listdev and syslog which is full of HDA-Messages.

If I play music files and specially if a tone if held some time this tone sounds rattling, distorted, a bit like a robot and a little unclean.
I have tested this with differend sound formats (WAV/MP3) and files, but not all sound like this. Perhaps this has s.th. to do with the dynamic or the frequency spectrum of the Soundsamples and sometimes the HDA is internally overamplifyed through wrong initalisation?!?

I have tested the same files with the newest Knoppix on this EeePC and there the sound is OK.

Attachments (2)

listdev.txt (2.5 KB) - added by jahaiku 10 years ago.
syslog.txt (63.5 KB) - added by jahaiku 10 years ago.

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by jahaiku

Attachment: listdev.txt added

Changed 10 years ago by jahaiku

Attachment: syslog.txt added

comment:1 Changed 10 years ago by jahaiku

I have retested with an AcerAspireOne and there the sound is OK.
So it must be related to the HDA-Chip used in the EeePC.

comment:2 Changed 9 years ago by bonefish

On my machine with Intel P55 Express chipset I can reproduce cracking noise. Switching the output frequency with a certain chance results in state without or with noise (leaning towards the noisy side). Doesn't seem to depend on the frequency. I've heard all supported frequencies with and without noise.

The syslog output is identical in both cases.

comment:3 Changed 9 years ago by stippi

Interesting. During improving the OSS node, which is based on the MultiAudio node, I was fighting a lot of cracking issues and these had to do with calculating latencies for buffers/connections and the drift. Since a while, I have perfect sound with HDA (P35 ?) at 192 kHz output. On my notebook as well. I could imagine the problems are with calculating latencies and perhaps also the drift. It may be interesting to diff the MultiAudio and OSS nodes to see what stuff I was working on.

comment:4 in reply to:  3 Changed 9 years ago by bonefish

Replying to stippi:

Interesting. During improving the OSS node, which is based on the MultiAudio node, I was fighting a lot of cracking issues and these had to do with calculating latencies for buffers/connections and the drift. Since a while, I have perfect sound with HDA (P35 ?) at 192 kHz output. On my notebook as well. I could imagine the problems are with calculating latencies and perhaps also the drift. It may be interesting to diff the MultiAudio and OSS nodes to see what stuff I was working on.

To clarify my above comment. The cracking I was referring to doesn't happen occasionally, but several times a second and seem to vary depending on what is played. Like noise introduced by incorrect resampling or something like that. Changing the audio format to avoid any kind of resampling and format conversion doesn't make a difference, though. Latency/time calculation bugs wouldn't explain why after switching the frequency (often several times), the sound is OK. It would, however, explain the occasional cracking, which does still happen -- particularly because I haven't seen any problem in DebugAnalyzer so far. So looking at the changes could indeed be helpful.

The main problem, I would guess, is indeed a driver issue. Maybe it doesn't set up the hardware exactly according to the specification or it does and particular chipsets want it slightly differently. I don't know, but that's where I would look first (if I had the motivation ;-)).

comment:5 Changed 9 years ago by bonefish

Resolution: fixed
Status: newclosed

Should be fixed in hrev34664. At least my problem is gone. Please reopen if your issue still persists.

Note: See TracTickets for help on using tickets.