Opened 10 years ago

Closed 10 years ago

#4085 closed bug (fixed)

Error with libtool-2.2.6a-x86-gcc2-2009-07-05.zip

Reported by: mmadia Owned by: zooey
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by mmadia)

The new package of libtool-2.2.6a-x86-gcc2-2009-07-05.zip has line 251:

: ${SED="/boot/common/bin/sed"}

The older package libtool-2.2.6a-gcc2-2008-11-09.zip has line 255:

: ${SED="/bin/sed"}

With the new libtoolize, certain programs, such as pkg-config-0.23 fail to be updated with libtoolize --force --copy because it's looking for the binary in the wrong place.

edit: to sum up, the issue is that the new libtoolize is configured to use /boot/common/bin/sed and in a default jam -q @alpha-raw image, there is no /boot/common/bin/sed

Change History (3)

comment:1 by mmadia, 10 years ago

Description: modified (diff)

comment:2 by scottmc, 10 years ago

this probaly happened when i build libtool with a newer sed in /boot/common rather than the one that comes with haiku. So there's two paths to fixing this one, either a new libtool package is needed pointing to the current sed, but then the current sed needs to be updated for the wchar fix. Or sed can be removed from haiku's tree and moved to an optional package... So this one might be tied to #3230.

comment:3 by zooey, 10 years ago

Resolution: fixed
Status: newclosed

In hrev31486, libtools has been reverted to the older version, as I can't see the point of adding an sed optional package when haiku already provides one (in /bin).

Note: See TracTickets for help on using tickets.