Opened 10 years ago

Closed 9 years ago

#4175 closed bug (fixed)

MediaPlayer crashes when seeking

Reported by: jackburton Owned by: dlmcpaul
Priority: normal Milestone: R1
Component: Applications/MediaPlayer Version: R1/Development
Keywords: gcc4 hybrid Cc: mdisreali@…
Blocked By: Blocking: #5237
Has a Patch: no Platform: All

Description (last modified by jackburton)

When seeking a video file which contains an audio track encoded with Mpeg 1 Layer 3, mediaplayer crashes. The correct way to reproduce is to click on the slider bar, keep the mouse button pressed, and move the mouse. It crashes 100% of the times. If just clicking on the slider once, it doesn't crash, and seeks correctly. I'll provide a backtrace soon. This is in hrev32060, gcc4 hybrid.

Attachments (2)

screenshot1.png (144.0 KB) - added by jackburton 10 years ago.
BackTrace
mediaplayer_mp3-decoder_crash_2010-04-23.txt (3.7 KB) - added by Disreali 9 years ago.

Download all attachments as: .zip

Change History (17)

comment:1 Changed 10 years ago by jackburton

Description: modified (diff)

Changed 10 years ago by jackburton

Attachment: screenshot1.png added

BackTrace

comment:2 Changed 10 years ago by jackburton

I suspect this could be a dup of #2486.

comment:3 Changed 10 years ago by dlmcpaul

Owner: changed from marcusoverhagen to dlmcpaul

I think there is something in the Audio Out Control of MediaPlayer that might be corrupting memory. I have a number of different media files that crash in various places but the common factor all seems to be the Audio Out Control is the thread that crashes.

comment:4 Changed 10 years ago by jackburton

Seems to be fixed. At least, I can't reproduce this anymore. Will recheck with other files before closing, though.

comment:5 Changed 10 years ago by stippi

jackburton: Do you mean since my round of fixes during the BeGeistert Coding Sprint? Or something else?

comment:6 in reply to:  4 ; Changed 10 years ago by jackburton

Replying to jackburton:

Seems to be fixed. At least, I can't reproduce this anymore. Will recheck with other files before closing, though.

I've tried with other files, and unfortunately it still crashes.

comment:7 in reply to:  6 ; Changed 10 years ago by dlmcpaul

Replying to jackburton:

Replying to jackburton:

Seems to be fixed. At least, I can't reproduce this anymore. Will recheck with other files before closing, though.

I've tried with other files, and unfortunately it still crashes.

Can I have an example file please.

And what revision are you running, I checked in a small fix for mp3_decoder recently that might have helped.

comment:8 in reply to:  7 Changed 10 years ago by jackburton

Replying to dlmcpaul:

Can I have an example file please.

Let's get in contact privately (via mail) and I'll get one to you.

And what revision are you running, I checked in a small fix for mp3_decoder recently that might have helped.

I'm current.

comment:9 Changed 10 years ago by dlmcpaul

dlmcpaul AT gmail com

comment:10 Changed 10 years ago by jackburton

Description: modified (diff)
Keywords: gcc4 hybrid added

comment:11 Changed 9 years ago by jackburton

Blocking: 5237 added

comment:12 Changed 9 years ago by Disreali

Cc: mdisreali@… added
Version: R1/pre-alpha1R1/Development

Experiencing this on hrev35434 gcc2hybrid built from trunk. Sound stops yet video continues. Including bt.

Changed 9 years ago by Disreali

comment:13 in reply to:  12 Changed 9 years ago by dlmcpaul

Replying to Disreali:

Experiencing this on hrev35434 gcc2hybrid built from trunk. Sound stops yet video continues. Including bt.

Are you able to send a link to the file or the file itself to dlmcpaul AT gmail com ?

comment:14 Changed 9 years ago by stippi

The MP3Decoder has code to "resync" itself after a seek. If the file plays through without seeking, then the error is almost guaranteed to be in the resyncing code inside the MP3Decoder.

comment:15 Changed 9 years ago by stippi

Resolution: fixed
Status: newclosed

The MP3 decoder has been disabled in favor of the FFmpeg plugin's support for MP3. So far I have not seen a single seeking crash with MP3 streams anymore.

Note: See TracTickets for help on using tickets.