Opened 10 years ago

Closed 10 years ago

#4210 closed bug (fixed)

userlandfs only creates volumes

Reported by: Blub Owned by: bonefish
Priority: normal Milestone: R1
Component: File Systems/UserlandFS Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

As far as I can see in the userlandfs code, Mount() creates a volume which is mounted, and deleted if mount files, but Unmount() doesn't delete the volume, neither can I find any other places where it might be deleted.

Another bug caused by this is that since fuse only allows one volume to be mounted, even after unmounting the current volume it is not possible to mount any other fuse-volumes without killing the userlandfs server hosting the related fuse filesystem.

I'd suggest them to be deleted when they're successfully unmounted.

Attachments (1)

haiku_delete_unmounted_userlandfs_volumes.diff (570 bytes) - added by Blub 10 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 10 years ago by bonefish

Component: - GeneralFile Systems/UserlandFS
Owner: changed from axeld to bonefish

comment:2 Changed 10 years ago by bonefish

Resolution: fixed
Status: newclosed

Thanks. Fixed in hrev32287.

Note: See TracTickets for help on using tickets.