Opened 13 years ago

Closed 13 years ago

Last modified 10 years ago

#423 closed bug (invalid)

[Beezer] Segment violation (part two)

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Beezer crash if you click twice on recent button in the welcome window.

GNU gdb 6.3 Copyright 2004 Free Software Foundation, Inc. GDB is free software, covered by the GNU General Public License, and you are welcome to change it and/or distribute copies of it under certain conditions. Type "show copying" to see the conditions. There is absolutely no warranty for GDB. Type "show warranty" for details. This GDB was configured as "i586-pc-haiku"...(no debugging symbols found)

Thread 384 caused an exception: Segment violation Reading symbols from /BeBox/apps/Beezer/lib/libCLV.so...(no debugging symbols found)...done. Loaded symbols for /BeBox/apps/Beezer/lib/libCLV.so Reading symbols from /boot/beos/system/lib/libbe.so...(no debugging symbols found)...done. Loaded symbols for /boot/beos/system/lib/libbe.so Reading symbols from /boot/beos/system/lib/libtracker.so... (no debugging symbols found)...done. Loaded symbols for /boot/beos/system/lib/libtracker.so Reading symbols from /boot/beos/system/lib/libtranslation.so...(no debugging symbols found)...done. Loaded symbols for /boot/beos/system/lib/libtranslation.so Reading symbols from /boot/beos/system/lib/libstdc++.hrev4.so... (no debugging symbols found)...done. Loaded symbols for /boot/beos/system/lib/libstdc++.hrev4.so Reading symbols from /BeBox/apps/Beezer/lib/libFSU.so...(no debugging symbols found)...done. Loaded symbols for /BeBox/apps/Beezer/lib/libFSU.so Reading symbols from /boot/beos/system/lib/libnet.so... (no debugging symbols found)...done. Loaded symbols for /boot/beos/system/lib/libnet.so Reading symbols from /boot/beos/system/lib/libroot.so...done. Loaded symbols for /boot/beos/system/lib/libroot.so Reading symbols from /boot/beos/system/lib/libsocket.so...done. Loaded symbols for /boot/beos/system/lib/libsocket.so

[Switching to team /BeBox/apps/Beezer/Beezer (379) thread Beezer (384)] 0x00273f8a in StartupWindow::MessageReceived () (gdb) bt #0 0x00273f8a in StartupWindow::MessageReceived () #1 0x00367263 in BLooper::DispatchMessage ()

from /boot/beos/system/lib/libbe.so

#2 0x003e1651 in BWindow::DispatchMessage ()

from /boot/beos/system/lib/libbe.so

#3 0x003e468c in BWindow::task_looper () from /boot/beos/system/lib/libbe.so #4 0x003687eb in BLooper::_task0_ () from /boot/beos/system/lib/libbe.so #5 0x00719850 in thread_entry () from /boot/beos/system/lib/libroot.so #6 0x7003ffec in ?? () (gdb)

Change History (4)

comment:1 Changed 13 years ago by axeld

Status: newclosed

comment:2 Changed 13 years ago by axeld

Since the source is not available, and I get a different stack crawl (caused by memory corruption), I won't look into this, sorry.

comment:3 Changed 13 years ago by axeld

Resolution: wontfix

comment:4 Changed 10 years ago by diver

Component: - GeneralKits/Interface Kit
Platform: All
Version: R1 development

Just to note, it doesn't crash anymore.

Note: See TracTickets for help on using tickets.