Opened 10 years ago

Closed 10 years ago

#4270 closed bug (fixed)

[Terminal] crash in TermView::FrameResized

Reported by: diver Owned by: jackburton
Priority: normal Milestone: R1
Component: Applications/Terminal Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Download webdings.ttf and copy it to /boot/common/fonts
Open Terminal->Preferences and change current font to webdings.

Thread 2329 caused an exception: Divide error
Reading symbols from /boot/system/runtime_loader...done.
Loaded symbols for /boot/system/runtime_loader
Reading symbols from /boot/system/lib/libbe.so...done.
Loaded symbols for /boot/system/lib/libbe.so
Reading symbols from /boot/system/lib/libgame.so...done.
Loaded symbols for /boot/system/lib/libgame.so
Reading symbols from /boot/system/lib/libtracker.so...done.
Loaded symbols for /boot/system/lib/libtracker.so
Reading symbols from /boot/system/lib/libtextencoding.so...done.
Loaded symbols for /boot/system/lib/libtextencoding.so
Reading symbols from /boot/system/lib/libroot.so...done.
Loaded symbols for /boot/system/lib/libroot.so
Reading symbols from /boot/system/lib/libstdc++.r4.so...done.
Loaded symbols for /boot/system/lib/libstdc++.r4.so
Reading symbols from /boot/system/lib/libmedia.so...done.
Loaded symbols for /boot/system/lib/libmedia.so
Reading symbols from /boot/system/lib/libtranslation.so...done.
Loaded symbols for /boot/system/lib/libtranslation.so
[tcsetpgrp failed in terminal_inferior: Invalid Argument]
[Switching to team /boot/system/apps/Terminal (2315) thread w>Terminal 1 (2329)]
0x0022976e in TermView::FrameResized ()
(gdb) bt
#0  0x0022976e in TermView::FrameResized ()
#1  0x003c199d in BView::MessageReceived () from /boot/system/lib/libbe.so
#2  0x0022a70c in TermView::MessageReceived ()
#3  0x003091e7 in BLooper::DispatchMessage () from /boot/system/lib/libbe.so
#4  0x003c94d1 in BWindow::DispatchMessage () from /boot/system/lib/libbe.so
#5  0x003cd0cc in BWindow::task_looper () from /boot/system/lib/libbe.so
#6  0x0030a743 in BLooper::_task0_ () from /boot/system/lib/libbe.so
#7  0x007fc124 in thread_entry () from /boot/system/lib/libroot.so
#8  0x700c1fec in ?? ()

Attachments (1)

crash.png (188.4 KB) - added by diver 10 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by jackburton

Resolution: fixed
Status: newclosed

This, too, was fixed in hrev33945, since Webdings isn't a fixed font. Note, though, that using this font in StyledEdit doesn't work, either. IOW: you don't get anything on screen.

comment:2 Changed 10 years ago by diver

Resolution: fixed
Status: closedreopened

Sorry, but it still crashes in hrev34006.

comment:3 Changed 10 years ago by jackburton

How can it crash, if you can't select webdings anymore ?

Changed 10 years ago by diver

Attachment: crash.png added

comment:4 Changed 10 years ago by diver

I can select it, see screenshot.

comment:5 Changed 10 years ago by jackburton

You're right. The problem is caused by our font subsystem not correctly setting the height and/or width of glyphs when using webdings. I can add a check in terminal to avoid the crash, but the real problem lies in our font subsystem.

comment:6 Changed 10 years ago by jackburton

Should be fixed (workarounded, actually) in hrev34019. Please confirm.

comment:7 Changed 10 years ago by diver

Confirmed. Webdings doesn't show up in preferences of terminal anymore.

comment:8 Changed 10 years ago by jackburton

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.