Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4271 closed bug (duplicate)

[Tracker] crash in BNode::GetAttrInfo ()

Reported by: diver Owned by: aldeck
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: #4130 Blocking:
Has a Patch: no Platform: All

Description

Press Alt+F, type webdings.ttf and hit return to create a query for that file. Open BeZillaBrowser and download webdings.ttf to the Desktop. Tracker should crash.
Tested with hrev32481 in VirtualBox 3.0.4

Thread 417 caused an exception: Segment violation
Reading symbols from /boot/system/runtime_loader...done.
Loaded symbols for /boot/system/runtime_loader
Reading symbols from /boot/system/lib/libbe.so...done.
Loaded symbols for /boot/system/lib/libbe.so
Reading symbols from /boot/system/lib/libtracker.so...done.
Loaded symbols for /boot/system/lib/libtracker.so
Reading symbols from /boot/system/lib/libroot.so...done.
Loaded symbols for /boot/system/lib/libroot.so
Reading symbols from /boot/system/lib/libstdc++.r4.so...done.
Loaded symbols for /boot/system/lib/libstdc++.r4.so
Reading symbols from /boot/system/lib/libtranslation.so...done.
Loaded symbols for /boot/system/lib/libtranslation.so
Reading symbols from /boot/system/lib/libtextencoding.so...done.
Loaded symbols for /boot/system/lib/libtextencoding.so
Reading symbols from /boot/system/apps/Workspaces...done.
Loaded symbols for /boot/system/apps/Workspaces
Reading symbols from /boot/system/add-ons/Translators/BMPTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/BMPTranslator
Reading symbols from /boot/system/add-ons/Translators/EXRTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/EXRTranslator
Reading symbols from /boot/system/lib/libilmimf.so...done.
Loaded symbols for /boot/system/lib/libilmimf.so
Reading symbols from /boot/system/lib/libz.so...done.
Loaded symbols for /boot/system/lib/libz.so
Reading symbols from /boot/system/add-ons/Translators/GIFTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/GIFTranslator
Reading symbols from /boot/system/add-ons/Translators/JPEG2000Translator...done.
Loaded symbols for /boot/system/add-ons/Translators/JPEG2000Translator
Reading symbols from /boot/system/add-ons/Translators/JPEGTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/JPEGTranslator
Reading symbols from /boot/system/add-ons/Translators/PCXTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/PCXTranslator
Reading symbols from /boot/system/add-ons/Translators/PNGTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/PNGTranslator
Reading symbols from /boot/system/add-ons/Translators/PPMTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/PPMTranslator
Reading symbols from /boot/system/add-ons/Translators/RAWTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/RAWTranslator
Reading symbols from /boot/system/add-ons/Translators/RTF-Translator...done.
Loaded symbols for /boot/system/add-ons/Translators/RTF-Translator
Reading symbols from /boot/system/add-ons/Translators/SGITranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/SGITranslator
Reading symbols from /boot/system/add-ons/Translators/STXTTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/STXTTranslator
Reading symbols from /boot/system/add-ons/Translators/TGATranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/TGATranslator
Reading symbols from /boot/system/add-ons/Translators/TIFFTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/TIFFTranslator
Reading symbols from /boot/system/add-ons/Translators/WonderBrushTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/WonderBrushTranslator
[tcsetpgrp failed in terminal_inferior: Invalid Argument]
[Switching to team /boot/system/Tracker (86) thread w>/boot/home/queries/Name = web (417)]
0x003a85e8 in BNode::GetAttrInfo () from /boot/system/lib/libbe.so
(gdb) bt
#0  0x003a85e8 in BNode::GetAttrInfo () from /boot/system/lib/libbe.so
#1  0x005befe5 in BPrivate::BPoseView::AttributeChanged ()
   from /boot/system/lib/libtracker.so
#2  0x005bdeb9 in BPrivate::BPoseView::FSNotification ()
   from /boot/system/lib/libtracker.so
#3  0x005b3b9c in BPrivate::BPoseView::MessageReceived ()
   from /boot/system/lib/libtracker.so
#4  0x005d3afa in BPrivate::BQueryPoseView::MessageReceived ()
   from /boot/system/lib/libtracker.so
#5  0x002c51e7 in BLooper::DispatchMessage () from /boot/system/lib/libbe.so
#6  0x003854d1 in BWindow::DispatchMessage () from /boot/system/lib/libbe.so
#7  0x003890cc in BWindow::task_looper () from /boot/system/lib/libbe.so
#8  0x002c6743 in BLooper::_task0_ () from /boot/system/lib/libbe.so
#9  0x0069e124 in thread_entry () from /boot/system/lib/libroot.so
#10 0x7003ffec in ?? ()
(gdb) 

Attachments (2)

crash-syslog.txt (2.4 KB ) - added by humdinger 10 years ago.
syslog tail
crash-KDL.png (50.9 KB ) - added by humdinger 10 years ago.
KDL screenshot

Download all attachments as: .zip

Change History (16)

comment:1 by anevilyak, 10 years ago

Is that crash reliably reproducible on VirtualBox? Same exact steps on real hardware show no crash, just the file showing up in the query as expected.

comment:2 by diver, 10 years ago

Yes, it's reproducible.

comment:3 by humdinger, 10 years ago

Can't reproduce with hrev32511, gcc4-hybrid, VirtualBox 3.0.4 But see that crash with the older pre-alpha-vmware hrev32435.

comment:4 by humdinger, 10 years ago

Just build the pre-alpha-vmware from hrev32511 and I still see the crash.
So, plain alpha-image crashes, the one build with a UserBuildConfig-profile doesn't... curious.

comment:5 by aldeck, 10 years ago

Strange, can't reproduce it either. Can you try on real hardware? There's some logic to wait while a node is busy which might misbehave on slow systems/emulators.

comment:6 by humdinger, 10 years ago

I just build the same hrev32511 as raw alpha-image and dd'ed it to a partition. Here, too, I see the same crash.

comment:7 by aldeck, 10 years ago

Owner: changed from axeld to aldeck
Status: newassigned

comment:8 by aldeck, 10 years ago

I'm a bit stuck, for once it's hard to reproduce, and i can't find a reason for BNode::GetAttrInfo(attrName, &info) to segfault. As always, i can't reproduce it after adding debug output grrr! The only crash where i had some info happened with an empty string for attrName.

Humdinger, when it crashes can you try something for me? Don't click the crash/debug dialog and enter manually the KDL (btw it's alt-syreq-d now). Type 'teams' to find Tracker's team id (x), and type 'threads x' to find the thread id (y) of your query window. Now type 'bt y'. This way we'll have more info since the kernel debugger shows function call arguments. You can copy/paste it there from /var/log/syslog.

comment:9 by humdinger, 10 years ago

I'd like to help, but in VirtualBox I can't call KDL. My sysreq key apparently like to take screenshots instead...
Strangely enough, the native installation won't show the bug anymore. Unfortunate, because there I can enter KDL at will. Is there another option to call KDL besides the keycombo that won't work for me in VirtualBox?

in reply to:  9 comment:10 by bonefish, 10 years ago

Replying to humdinger:

Strangely enough, the native installation won't show the bug anymore. Unfortunate, because there I can enter KDL at will. Is there another option to call KDL besides the keycombo that won't work for me in VirtualBox?

You can add the "kernel_debugger" CLI command via your UserBuildConfig and invoke from the Terminal then.

comment:11 by humdinger, 10 years ago

Thanks, Ingo. That worked!

Attached is a text file of the last couple of lines from the syslog, plus a PNG of the KDL screen (the text has "scrolled around" the KDL window, so the end is actually at the top.

HTH.

by humdinger, 10 years ago

Attachment: crash-syslog.txt added

syslog tail

by humdinger, 10 years ago

Attachment: crash-KDL.png added

KDL screenshot

comment:12 by aldeck, 10 years ago

Ok! thanks a lot, the BNode pointer is NULL. Will investigate.

comment:13 by aldeck, 10 years ago

Blocked By: 4130 added
Resolution: duplicate
Status: assignedclosed

Most certainly a duplicate of #4130, fixed in hrev33744. Please test

comment:14 by aldeck, 10 years ago

For reference, a test that was triggering the bug:

mkdir /tmp/tt; cd /tmp/tt; open .; while true; do touch $(seq 100); addattr "test" "hey" $(seq 100); rm $(seq 100); done
Note: See TracTickets for help on using tickets.