Opened 10 years ago

Closed 8 years ago

#4278 closed bug (fixed)

[MediaPlayer] crash after several start/close sessions

Reported by: diver Owned by: nobody
Priority: normal Milestone: R1
Component: Applications/MediaPlayer Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

If I open a video file several times, MediaPlayer would crash

Thread 1604 caused an exception: Segment violation
Reading symbols from /boot/system/runtime_loader...done.
Loaded symbols for /boot/system/runtime_loader
Reading symbols from /boot/system/lib/libbe.so...done.
Loaded symbols for /boot/system/lib/libbe.so
Reading symbols from /boot/system/lib/libgame.so...done.
Loaded symbols for /boot/system/lib/libgame.so
Reading symbols from /boot/system/lib/libmedia.so...done.
Loaded symbols for /boot/system/lib/libmedia.so
Reading symbols from /boot/system/lib/libtracker.so...done.
Loaded symbols for /boot/system/lib/libtracker.so
Reading symbols from /boot/system/lib/libtranslation.so...done.
Loaded symbols for /boot/system/lib/libtranslation.so
Reading symbols from /boot/system/lib/libtextencoding.so...done.
Loaded symbols for /boot/system/lib/libtextencoding.so
Reading symbols from /boot/system/lib/libstdc++.r4.so...done.
Loaded symbols for /boot/system/lib/libstdc++.r4.so
Reading symbols from /boot/system/lib/libroot.so...done.
Loaded symbols for /boot/system/lib/libroot.so
[tcsetpgrp failed in terminal_inferior: Invalid Argument]
[Switching to team /boot/system/apps/MediaPlayer (1588) thread frame generator (1604)]
0x00a3d743 in ?? ()
(gdb) bt
#0  0x00a3d743 in ?? ()
#1  0x18044ac8 in ?? ()
#2  0x782c993c in ?? ()
#3  0x782c9940 in ?? ()
#4  0x782c9a4c in ?? ()
#5  0x00dbb38c in ?? ()
#6  0x094e3000 in ?? ()
#7  0x782c9ce4 in ?? ()
#8  0x00948744 in posix_memalign () from /boot/system/lib/libroot.so
#9  0x00a3cf8b in ?? ()
#10 0x18044ac8 in ?? ()
#11 0x094e3000 in ?? ()
#12 0x782c9ce4 in ?? ()
#13 0x782c9bac in ?? ()
#14 0x00000000 in ?? ()
#15 0x1801f4a0 in ?? ()
#16 0x782c9c1c in ?? ()
#17 0x00a3cf1e in ?? ()
#18 0x005c9c64 in ?? () from /boot/system/lib/libmedia.so
#19 0x782c9bac in ?? ()
#20 0x1808fd20 in ?? ()
#21 0x005868e5 in BMediaTrack::DecodedFormat ()
   from /boot/system/lib/libmedia.so
#22 0x00586da4 in BMediaTrack::ReadFrames () from /boot/system/lib/libmedia.so
---Type <return> to continue, or q <return> to quit---
#23 0x00586cfe in BMediaTrack::ReadFrames () from /boot/system/lib/libmedia.so
#24 0x0025b44f in MediaTrackVideoSupplier::ReadFrame ()
#25 0x0025cd9c in ProxyVideoSupplier::FillBuffer ()
#26 0x00248cac in VideoProducer::_FrameGeneratorThread ()
#27 0x00248613 in VideoProducer::_FrameGeneratorThreadEntry ()
#28 0x00938124 in thread_entry () from /boot/system/lib/libroot.so
#29 0x782c9fec in ?? ()
(gdb) 

Change History (5)

comment:1 Changed 9 years ago by marcusoverhagen

Owner: changed from marcusoverhagen to nobody
Status: newassigned

comment:2 Changed 9 years ago by stippi

Seems like MediaPlayer corrupted its memory. Can you still reproduce it with the same stream? If yes, I'd appreciate a test file!

comment:3 Changed 9 years ago by diver

Sorry, I don't remember which file I used to crash MediaPlayer, but I'll try to reproduce it anyway.

comment:4 Changed 8 years ago by halilpk

Haiku revision: hrev42211 not a bug. I have opened 15 video file. When i opened 12th file it was still playing without problem but after 12th file there was just little freezing. System: Haiku hrev1-alpha3 on VMware workstation 8 on windows 7 32 bit

comment:5 Changed 8 years ago by diver

Resolution: fixed
Status: assignedclosed

Probably fixed then.

Note: See TracTickets for help on using tickets.