Opened 13 years ago

Closed 12 years ago

#432 closed bug (fixed)

Black screen on laptop, works only with radeon driver from Bebits

Reported by: kutspam@… Owned by: euan
Priority: normal Milestone: R1
Component: System/Kernel Version:
Keywords: Cc: diver, umccullough
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

There some weird thing with this driver and ati mobility m6 in the HP nc4010. Zeta: screen switches to black after boot icons, BeOS with same? bebits driver too, solution: remove driver, reboot, reinstall, reboot works. In zeta select Use panel = always in screen prefs and your sceen won't go black after colour depth changes.

In haiku the 'remove driver, reboot, reinstall, reboot'-method won't work, screen stays black. With radeon driver from bebits this method works but I can't set sceen resolution or colour depth (it won't change anything).

Change History (12)

comment:1 Changed 13 years ago by korli

IRQ is deactivated in Haiku Radeon driver (by axeld). To have it working along an audio driver (for the same IRQ IIRC), I had to activate IRQ again.

comment:2 Changed 13 years ago by kutspam@…

Where / how can I activate the IRQ for VGA? I'd like to test it. If I use the radeon driver from Bebits, should the screen prefs work? Do the screen prefereces work at all? There's like I said before an issue with the panel (screen) not being activated and thus the screen stays black, who maintains the driver?

comment:3 Changed 13 years ago by diver

Cc: diver added

comment:4 Changed 13 years ago by kutspam@…

Seems that the backlight isn't always activated with the bebits radeon driver (originally by Tomas Kurschel, now maintained by Euan). Could be related, see the bebits talkback if you have time.

comment:5 Changed 13 years ago by jackburton

This bug should have been fixed already, since interrupts have been reactivated for the radeon driver.

comment:6 Changed 13 years ago by kutspam@…

This bug still persists, I had to put an external monitor to the vga out to get a picture to be able to set the "Use laptop panel" "Always" After that it works.

comment:7 Changed 13 years ago by kutspam@…

This time a installed Haiku rev 18081 over the older version but didn't replace the settings folder in /boot/home/config/settings.

radeon driver works normally.

comment:8 Changed 13 years ago by umccullough@…

I cannot get the latest Radeon driver to work with Haiku (18203) at all with my Radeon 9200 AGP. I also have an SB Live Value! in this machine - if that matters.

I had to revert 17279 and rebuild the driver in order to successfully boot Haiku with it again.

comment:9 Changed 13 years ago by umccullough@…

Cc: umccullough@… added

comment:10 Changed 13 years ago by marcusoverhagen

Owner: marcusoverhagen deleted
Platform: All

comment:11 Changed 12 years ago by euan

Owner: set to euan

I'm thinking this bug is closed now?

9200 bug was hrev20336 #1079 and the backlight issue was semi-solved for those lucky people shortly later?

AFAIK there still are people with Back lights that don't function. I'd like to blame them on ACPI or other... ;)

I feel new tickets for those unlucky people would be easier for traceability, given the number of changes to the driver in the last 12 months. If anyone wishes to post a new ticket for backlight issues, can they post a syslog (with file name containing reporters name + laptop model). Everyone else just pile on more syslogs in a similar fashion.

If no objections I'll close this ticket.

comment:12 Changed 12 years ago by euan

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.