Opened 10 years ago

Closed 8 years ago

Last modified 8 years ago

#4328 closed bug (fixed)

[bin:top] 5 seconds is too much before displaying

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Command Line Tools Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: yes Platform: All

Description

Currently one have to wait 5 seconds before top will display process list, this is too much when you just want to quickly look around. It is also is too limited in options, maybe there is a bsd version?

Attachments (1)

patch_top.diff (1.2 KB) - added by stpere 8 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 10 years ago by korli

ps might be the tool you want to use then. top needs a little time to be able to display valid stats.

comment:2 Changed 10 years ago by jackburton

The problem is that the default delay for top is 5 seconds. But that delay shouldn't be applied before showing the initial screen.

comment:3 Changed 10 years ago by diver

Thanks Jerome, ps will do for now. BTW (sorry for offtopic), could you please have a look at auich driver in wrt VirtualBox, pretty please? :-)

comment:4 Changed 9 years ago by diver

Version: R1/pre-alpha1R1/Development

comment:5 Changed 9 years ago by diver

Still here in hrev38300.

comment:6 Changed 9 years ago by mmadia

Edited comment as the issue was explained over IRC.

Last edited 9 years ago by mmadia (previous) (diff)

Changed 8 years ago by stpere

Attachment: patch_top.diff added

comment:7 Changed 8 years ago by stpere

Has a Patch: set

comment:8 Changed 8 years ago by stpere

Can't commit yet, but when in "infinite iterations" mode, the first iteration will be done in half a second, then the others will follow the requested delay.

comment:9 Changed 8 years ago by bonefish

Applied in hrev42969. Thanks a lot and sorry for the delay!

comment:10 Changed 8 years ago by bonefish

Resolution: fixed
Status: newclosed

comment:11 Changed 8 years ago by stpere

Oh.. I'm sorry. I should have committed this myself before.. it slipped out of my mind. Thanks!!

Note: See TracTickets for help on using tickets.