Opened 10 years ago

Closed 10 years ago

#4362 closed bug (fixed)

Freeze during boot on core2 quad E6600

Reported by: marcusoverhagen Owned by: mmlr
Priority: critical Milestone: R1/alpha1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc: nielx
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Haiku freezes during boot on a core2 quad E6600 (at 2,4GHz) shortly after MTRR initialization. Entering KDL is not possible (PS/2 and USB keyboard)

When disabling SMP it boots, tested with hrev32769. (entering KDL also works)

The last version tested that didn't freeze (even overclocked at 3.0 GHz) was hrev30474.

Change History (7)

comment:1 Changed 10 years ago by mmlr

Owner: changed from axeld to mmlr
Priority: normalcritical
Status: newassigned

I can reproduce the same on my Q6600. This is a recent regression, as hrev32438 still worked fine. I have removed ATA to see if it was caused by the switch, but it didn't make a difference (booting from SATA over AHCI, so don't really need ATA). I'd say that's a critical regression. Will binary search to find the problem.

comment:2 Changed 10 years ago by phoudoin

I've the same feeling here, some change(s) in last 2 weeks make SMP unstable, as the issue doesn't show without real support for actual parallelism.

comment:3 Changed 10 years ago by mmlr

I'm binary searching the issue. Last working hrev32739, building hrev32760 now. Will find it eventually.

comment:4 Changed 10 years ago by nielx

Cc: nielx added

comment:5 Changed 10 years ago by marcusoverhagen

I didn't find the time yet to bisect that issue, but I verified that hrev30700 with ata patch from hrev32769 applied does boot just fine in SMP mode, using the ata stack.

comment:6 Changed 10 years ago by marcusoverhagen

hrev32500 works, too

comment:7 Changed 10 years ago by marcusoverhagen

Resolution: fixed
Status: assignedclosed

Bug found in hrev32679. Fixed in hrev32817.

Note: See TracTickets for help on using tickets.