Opened 10 years ago

Closed 8 years ago

#4388 closed bug (fixed)

Python's test_signal.py fails [Errno -2147454933] Operation not supported

Reported by: scottmc Owned by: bonefish
Priority: normal Milestone: R1
Component: System/POSIX Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by bonefish)

/boot/common/lib/python2.6/test> python test_signal.py
test_getsignal (__main__.BasicSignalTests) ... ok
test_out_of_range_signal_number_raises_error (__main__.BasicSignalTests) ... ok
test_setting_signal_handler_to_none_raises_error (__main__.BasicSignalTests) ... ok
test_main (__main__.InterProcessSignalTests) ... test runner's pid is 27228
handlerA invoked from signal 1 at:
  File "/boot/common/lib/python2.6/subprocess.py", line 1123, in wait
    pid, sts = os.waitpid(self.pid, 0)

handlerB invoked from signal 18 at:
  File "/boot/common/lib/python2.6/subprocess.py", line 1123, in wait
    pid, sts = os.waitpid(self.pid, 0)

HandlerBCalled exception caught
KeyboardInterrupt (the alarm() went off)
ok
test_wakeup_fd_during (__main__.WakeupSignalTests) ... ok
test_wakeup_fd_early (__main__.WakeupSignalTests) ... ok
test_siginterrupt_off (__main__.SiginterruptTest) ... ok
test_siginterrupt_on (__main__.SiginterruptTest) ... ok
test_without_siginterrupt (__main__.SiginterruptTest) ... ok
test_itimer_exc (__main__.ItimerTest) ... ok
test_itimer_prof (__main__.ItimerTest) ... ERROR
ERROR
test_itimer_real (__main__.ItimerTest) ... 
call pause()...
('SIGALRM handler invoked', (14, <frame object at 0x181dbb9c>))
ok
test_itimer_virtual (__main__.ItimerTest) ... ERROR
ERROR

======================================================================
ERROR: test_itimer_prof (__main__.ItimerTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "test_signal.py", line 375, in test_itimer_prof
    signal.setitimer(self.itimer, 0.2, 0.2)
ItimerError: [Errno -2147454933] Operation not supported

======================================================================
ERROR: test_itimer_prof (__main__.ItimerTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "test_signal.py", line 308, in tearDown
    signal.setitimer(self.itimer, 0)
ItimerError: [Errno -2147454933] Operation not supported

======================================================================
ERROR: test_itimer_virtual (__main__.ItimerTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "test_signal.py", line 361, in test_itimer_virtual
    signal.setitimer(self.itimer, 0.3, 0.2)
ItimerError: [Errno -2147454933] Operation not supported

======================================================================
ERROR: test_itimer_virtual (__main__.ItimerTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "test_signal.py", line 308, in tearDown
    signal.setitimer(self.itimer, 0)
ItimerError: [Errno -2147454933] Operation not supported

----------------------------------------------------------------------
Ran 13 tests in 5.440s

FAILED (errors=4)
Traceback (most recent call last):
  File "test_signal.py", line 392, in <module>
    test_main()
  File "test_signal.py", line 388, in test_main
    WakeupSignalTests, SiginterruptTest, ItimerTest)
  File "/boot/common/lib/python2.6/test/test_support.py", line 722, in run_unittest
    _run_suite(suite)
  File "/boot/common/lib/python2.6/test/test_support.py", line 705, in _run_suite
    raise TestFailed(err)
test.test_support.TestFailed: errors occurred; run in verbose mode for details
/boot/common/lib/python2.6/test> 

Change History (3)

comment:1 Changed 8 years ago by scottmc

Component: - GeneralSystem/POSIX
Owner: changed from axeld to bonefish
Status: newassigned

comment:2 Changed 8 years ago by bonefish

Description: modified (diff)
Version: R1/pre-alpha1R1/Development

From what I can guess from the output the issue is our incomplete interval timer support. Cf. setitimer().

comment:3 Changed 8 years ago by bonefish

Resolution: fixed
Status: assignedclosed

Should be fixed in hrev42116.

Note: See TracTickets for help on using tickets.