Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4432 closed bug (fixed)

HDA causes reboot

Reported by: lkernan Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Audio/HDA Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I'm testing the R32930 R1A1rc iso from haiku-files.org

The computer boots to the desktop, the icons and deskbar appear and then there is a second or so of very loud static noise. The computer then reboots automatically, there is no chance to go to KDL.

Booting in safe mode or deleting the HDA driver allows Haiku to boot and run normally.

I would have attached the syslog, but i couldn't locate it using the find command on the menu.

Attachments (17)

listdev-output.txt (3.6 KB ) - added by lkernan 10 years ago.
sysinfo-output.txt (2.7 KB ) - added by lkernan 10 years ago.
syslog (62.2 KB ) - added by lkernan 10 years ago.
media_server_crash.jpg (161.6 KB ) - added by lkernan 10 years ago.
media_server-log-part-1.JPG (72.1 KB ) - added by lkernan 10 years ago.
media_server-log-part-2.JPG (312.4 KB ) - added by lkernan 10 years ago.
Media_server-log-part-3.jpg (370.1 KB ) - added by lkernan 10 years ago.
hda syslog1.jpg (137.2 KB ) - added by lkernan 10 years ago.
hda syslog 3.jpg (133.2 KB ) - added by lkernan 10 years ago.
hda syslog 1.jpg (153.2 KB ) - added by lkernan 10 years ago.
hda syslog 2.jpg (163.3 KB ) - added by lkernan 10 years ago.
hda syslog 3.JPG (215.2 KB ) - added by lkernan 10 years ago.
syslog-oss (87.3 KB ) - added by lkernan 10 years ago.
mtrr-out.txt (207 bytes ) - added by kliput 10 years ago.
Linux /proc/mtrr on ASUS M51Tr
media_server_log.txt (681 bytes ) - added by kliput 10 years ago.
media_server output on ASUS M51Tr
media_server_log_wohda.txt (17.5 KB ) - added by kliput 10 years ago.
media_server output on ASUS M51Tr without some files (more info in post)
syslog.2 (94.8 KB ) - added by lkernan 10 years ago.

Download all attachments as: .zip

Change History (39)

by lkernan, 10 years ago

Attachment: listdev-output.txt added

by lkernan, 10 years ago

Attachment: sysinfo-output.txt added

comment:1 by mmadia, 10 years ago

From Terminal open /var/log/. Alternatively, open <volume_name>/var/log That'll display the folder that contains syslog

in reply to:  1 comment:2 by lkernan, 10 years ago

Replying to mmadia:

From Terminal open /var/log/. Alternatively, open <volume_name>/var/log That'll display the folder that contains syslog

I just checked, there was no log folder in /var until i created it. This is booting from a clean install to the hard drive from the cd. After creating the folder i rebooted and /var/log was still empty. Is it possible the syslog doesn't get created or updated when booting in safe mode?

comment:3 by lkernan, 10 years ago

I've done some more testing. If i remove the lines from the bootscript that prevent syslog running in safemode then i get a log from safe mode, so that part proves the syslog can work.

The log doesn't get created at all on a normal boot though. I guess the reboot is happening before anything gets written to disk.

I tried to get serial port output through a usb to serial dongle but that didn't work. The computer doesn't have a built in serial port.

If i turn on on screen debug output then all the boot icons light up, then the screen clears, but never gets to the desktop.

I'm running out of ideas on how to get some more useful information.

comment:4 by korli, 10 years ago

Can you try to comment the media_server launch in the BootScript ? It should get you to the desktop. You can then use a Terminal to tail the syslog ("tail -f /var/log/syslog"), another Terminal to launch the media_server ("/system/servers/media_server"). Hope it helps.

in reply to:  4 comment:5 by lkernan, 10 years ago

Replying to korli:

Can you try to comment the media_server launch in the BootScript ? It should get you to the desktop. You can then use a Terminal to tail the syslog ("tail -f /var/log/syslog"), another Terminal to launch the media_server ("/system/servers/media_server"). Hope it helps.

Thanks, that helped a lot. I was able to get the syslog and a bad photo of the media_server just as it rebooted. I'm just heading off to work now, i'll try and get a better photo tonight. I've posted this one in the hope it helps a little bit.

by lkernan, 10 years ago

Attachment: syslog added

by lkernan, 10 years ago

Attachment: media_server_crash.jpg added

by lkernan, 10 years ago

Attachment: media_server-log-part-1.JPG added

by lkernan, 10 years ago

Attachment: media_server-log-part-2.JPG added

by lkernan, 10 years ago

Attachment: Media_server-log-part-3.jpg added

comment:6 by lkernan, 10 years ago

I've just posted 3 images that show all the lines put out during media_server startup.

The static noise starts after the first few lines and the reboot comes just after the line about RegisterReader, name wav_reader.

I've tested about 10 times and the reboot is consistantly right after that line.

comment:7 by lkernan, 10 years ago

I've just installed an upgraded build, 33055, which i built myself from svn trunk. In this build the system still plays static and then reboots. This build is a hybrid gcc2 and 4 built with jam @alpha-cd.

Attaching some images from tail -f /var/log/syslog output as media_server starts. There are a lot of messages flying past very quickly, so i'll keep trying to get more of them.

by lkernan, 10 years ago

Attachment: hda syslog1.jpg added

by lkernan, 10 years ago

Attachment: hda syslog 3.jpg added

comment:8 by korli, 10 years ago

The syslog seems right to me. There is some display glitch (end of lines missing somehow). Did you check OSS wasn't installed ? It shouldn't be if you used alpha-iso.

Will you attend Begeistert ?

in reply to:  8 comment:9 by lkernan, 10 years ago

Replying to korli:

The syslog seems right to me. There is some display glitch (end of lines missing somehow). Did you check OSS wasn't installed ? It shouldn't be if you used alpha-iso.

Will you attend Begeistert ?

The missing end of lines in terminal has been happening to me for quite a few builds. It also happens with the alpha isos i downloaded.

There was an opensound file in the media\addons folder, so i deleted it. It didn't make any difference after a restart. The same thing happened.

I wish i could attend, but it is a long way to travel from Australia, so no.

by lkernan, 10 years ago

Attachment: hda syslog 1.jpg added

by lkernan, 10 years ago

Attachment: hda syslog 2.jpg added

by lkernan, 10 years ago

Attachment: hda syslog 3.JPG added

comment:10 by lkernan, 10 years ago

Ok, i've tried to replace a cople of the photos.

  1. As much as i prefer the white on black terminal, it doesn't cut anything off if i leave the default settings. So i redid the shots with the default settings.
  1. I removed everything from the /system/boot/addons/media folder except hd multi audio. That just makes the logs a bit easier to follow.
  1. In the 3rd file i just uploaded, i finally managed to catch the start of initialisation of the card. This is the first time i have managed to get a shot of it as the static starts. Not sure if it is helpful or not.

comment:11 by kliput, 10 years ago

Hello. I'm testing Haiku R1/Alpha1 and the same problem occurs on ASUS M51Tr notebook with HDA soundcard, but I didn't hear any sound/noise during boot (maybe it's related to problem with muted speakers, but not headphones audio output, I've got the same problem on older Linux kernels BTW). System restarts after showing up desktop, icons and tracker. I've comment out media_server from bootscript and it boots normally. When I try to run media_server manually, it just restart. I can help with debugging.

--- sorry for my poor English...

comment:12 by korli, 10 years ago

Hello.

  1. Could you run a "cat /proc/mtrr" on Linux ?
  2. Could you try to run with OSS instead of the hda driver ?

Thanks!

in reply to:  12 comment:13 by lkernan, 10 years ago

Replying to korli:

  1. Could you run a "cat /proc/mtrr" on Linux ?

This is straight from an Ubuntu live cd.

ubuntu@ubuntu:~$ cat /proc/mtrr reg00: base=0x000000000 ( 0MB), size= 2048MB, count=1: write-back reg01: base=0x0d0000000 ( 3328MB), size= 128MB, count=1: write-combining reg02: base=0x07ff00000 ( 2047MB), size= 1MB, count=1: uncachable ubuntu@ubuntu:~$

comment:14 by lkernan, 10 years ago

Sorry, should have put that in a code block:

ubuntu@ubuntu:~$ cat /proc/mtrr
reg00: base=0x000000000 (    0MB), size= 2048MB, count=1: write-back
reg01: base=0x0d0000000 ( 3328MB), size=  128MB, count=1: write-combining
reg02: base=0x07ff00000 ( 2047MB), size=    1MB, count=1: uncachable
ubuntu@ubuntu:~$

in reply to:  12 comment:15 by lkernan, 10 years ago

Replying to korli:

  1. Could you try to run with OSS instead of the hda driver ?

I just tried removing hda and installing oss. The media server detected the hardware and started ok, but no sound could be heard. I tried playing a wav file in media player and vlc and although both said they were playing, no sound.

The same setup, volume, etc plays sound fine in Windows or Ubuntu, so i know the hardware is ok.

I'll attach a syslog with oss installed instead of hda.

by lkernan, 10 years ago

Attachment: syslog-oss added

comment:16 by lkernan, 10 years ago

Oops, i spoke too soon. I had actually downloaded the opensound package from haiku-files and installed it. Turns out i needed to restart before it would work correctly.

Mediaplayer is playing files from my windows drives itunes library as i write this. The syslog-oss file i just sent is taken from after the restart so it shows the card in a working state.

by kliput, 10 years ago

Attachment: mtrr-out.txt added

Linux /proc/mtrr on ASUS M51Tr

by kliput, 10 years ago

Attachment: media_server_log.txt added

media_server output on ASUS M51Tr

by kliput, 10 years ago

Attachment: media_server_log_wohda.txt added

media_server output on ASUS M51Tr without some files (more info in post)

comment:17 by kliput, 10 years ago

I've attached output from Linux's /proc/mtrr.

I've tried to install OSS drivers from OSS homepage, but I don't know, wheter I did it correct. I've just unpacked oss-beos-v4.1test.zip to suitable directories and launched media_server:

  • system just hangs, but not "deadly" - I wasn't able to move cursor and first core of my CPU was working 100%, but I was able to restart system or kill media_server with ALT-CTRL-DEL
  • launched system in safe mode
  • removed /system/add-ons/kernel/drivers/dev/audio/hmulti directory (don't ask me why, I'm just using Haiku for few days and think that might be HDA drivers)
  • load ./media_server
  • tried to launch /Haiku/home/config/bin/osstest, and it works on: HD Audio play pcm1 (/dev/oss/oss_hdaudio0/pcm0) - plays sound!

Unfortunately MediaPlayer doesn't plays anything.

  • tried to launch "ossdevlinks", but it can't create symlink (/dev/dsp0 -> /dev/oss/oss_hdaudio0/pcm0)
  • tried to launch media_addon_server (I don't notice it was launched before): osstest can't play sound with pcm1 ("device busy")
  • second try to launch media_server with /system/add-ons/kernel/drivers/dev/audio/hmulti files: first it hangs, but I've killed media_server and media_addon_server, and tried to launch these second time - it loads. In Media settings there is new HD Audio device (there was only one before). It "sounds strange" - speakers sometimes turns on, sometimes off, sometimes, automatically, right channel of all controls goes 100%, and left goes 0%. Sometimes sound from MediaPlayer works too.

I've attached: media_server outputs with /system/add-ons/kernel/drivers/dev/audio/hmulti files, and without.

comment:18 by kliput, 10 years ago

I've deleted old OSS files (which I get from OSS main site) and installed "OpenSound-x86-gcc2-2008-06-21" package from haiku-files.org: now on normal startup I have full system hang on desktop and constant, but "very random" loud noise from my speakers.
Excuse me, if I'm doing something wrong with installing these files and there are bugs from there. Maybe I should do it in different way... I will search over internet about it. But maybe my sound card model is different and more difficult to debug.

by lkernan, 10 years ago

Attachment: syslog.2 added

comment:19 by lkernan, 10 years ago

Good news everybody! I've just installed rev 34903 (the first i've built since before the holidays)

The HDA driver now runs my Via sound perfectly! No crashes and music plays perfectly. I've uploaded the syslog (syslog.2) in case anyones interested.

This ticket can be closed as far as i'm concerned. Thanks to everyone who helped with this.

comment:20 by stippi, 10 years ago

Resolution: fixed
Status: newclosed

kliput, can you confirm the issue is fixed for you as well? Please re-open if not.

Thanks for the feedback, lkernan!

comment:21 by kliput, 10 years ago

Please forgive my late reply.

Now system doesn't reboot, but there's still no sound (I've tried to change sound levels, but without result).

I will try with the newest nightly build and OSS drivers.

PS. Should I reopen this ticket or close it and move to something like "No sound on ASUS M51Tr notebook"?

comment:22 by kliput, 10 years ago

OK, it's a bit strange, but when I enabled ACPI and reboot Haiku 2 times, soundcard started to work! At first boot, it wasn't work.

Nightly release I've tested: build 35539, GCC4 hybrid.

Note: See TracTickets for help on using tickets.