Opened 10 years ago

Closed 9 years ago

#4431 closed bug (fixed)

Panic: calling unlock_memory() on unmapped memory!

Reported by: mmadia Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/alpha1
Keywords: Cc:
Blocked By: Blocking: #5014
Has a Patch: no Platform: All

Description (last modified by mmadia)

x86gcc2, trunk rev 32950, native.

the following command will eventually result in a KDL.

svn co http://svn.osdrawer.net/bezilla

This was performed on a freshly initialized BFS volume with 2k block size.

machine listdev note, this is a dual core machine and with 2x2gb ram. bug not tested with smp disabled.

I was attempting to reproduce another bug with the svn command. however, this different bug appeared.

Attachments (3)

P1010023.JPG (282.8 KB) - added by mmadia 10 years ago.
bt
P1010024.JPG (334.4 KB) - added by mmadia 10 years ago.
traced -1 -100
screenshot-bug-4431.png (33.4 KB) - added by StephaneCharette 10 years ago.
screenshot of backtrace

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by mmadia

Attachment: P1010023.JPG added

bt

Changed 10 years ago by mmadia

Attachment: P1010024.JPG added

traced -1 -100

comment:1 Changed 10 years ago by mmadia

Description: modified (diff)

comment:2 Changed 10 years ago by mmadia

Description: modified (diff)

comment:3 Changed 10 years ago by StephaneCharette

I have almost the same happen to me this morning while doing a "jam clean;jam -j4 -q haiku-cd" on Haiku hrev33344. Some of the numbers are different. From the output on the screen, it looks like it was still doing the clean and hadn't started building yet.

Thing is, I don't have SCSI on my system, and USB is disabled on this VM, so I don't know why a "scsi scheduler" thread is running. Will attach screen shot of my bt.

Changed 10 years ago by StephaneCharette

Attachment: screenshot-bug-4431.png added

screenshot of backtrace

comment:4 Changed 10 years ago by nielx

Version: R1 alpha1R1/alpha1

comment:5 Changed 9 years ago by bonefish

Blocking: 5014 added

(In #5014) Duplicate of #4431.

comment:6 Changed 9 years ago by bonefish

Resolution: fixed
Status: newclosed

Should be fixed in hrev34655.

Note: See TracTickets for help on using tickets.