Opened 5 years ago

Last modified 16 months ago

#4482 reopened bug

Error: Device recalibrate error during install

Reported by: TechnoMancer Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/alpha3
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

The installer aborts during copy of acknowledgements.html file 35 of 16838
it gives the message:
An error was encountered and the installation was not completed:
Error: Device recalibrate error

revision: hrev33067
this file: http://haiku-files.org/releases/R1Alpha1/haiku-r1a1-rc-r33067-x86gcc2hybrid-iso.zip

cd drive appears to be a brandless 52x max cd-rom drive

Change History (19)

comment:1 in reply to: ↑ description Changed 5 years ago by zblace

  • Platform changed from All to x86

Replying to TechnoMancer:

The installer aborts during copy of acknowledgements.html file 35 of 16838
it gives the message:
An error was encountered and the installation was not completed:
Error: Device recalibrate error

revision: hrev33067
this file: http://haiku-files.org/releases/R1Alpha1/haiku-r1a1-rc-r33067-x86gcc2hybrid-iso.zip

cd drive appears to be a brandless 52x max cd-rom drive

same issue while installing on IBM T21

comment:2 Changed 5 years ago by nielx

  • Version changed from R1 alpha1 to R1/alpha1

comment:3 Changed 4 years ago by diver

Several people reports that they see this error while copying libwebcore.so. Could this be related to the file size, which is about 20 mb and appears to be the largest binary on the image?

comment:4 follow-up: Changed 4 years ago by diver

Could this be a dup of #6036?

comment:5 in reply to: ↑ 4 Changed 4 years ago by TechnoMancer

Replying to diver:

Could this be a dup of #6036?

Technically that is a dup of this one, this was a bug I filed from R1/A1 days when I failed to install from a CD, I did not check any extra info though so this ticket isn't very useful...

comment:6 Changed 4 years ago by aldeck

From all the reports i've seen and my own experience, those two tickets are most probably unrelated. This one might just be an actual bad burn. TechnoMancer, did you try different burns / media / reader? Was it failing always on that file? Note that for #6036 all the other reports failed on the same file: libwebcore.so with the same "General system error" message, and with a checksum verified cd.

I've read some confused comments but iirc those people weren't experiencing the problem directly.

I'm not sure of the exact meaning of your error message, but it sounds like an actual optical failure, ie: bad burn / media / lens or incompatible burner/reader pair (possibly due to wear out).

comment:7 Changed 4 years ago by TechnoMancer

Yes in my opinion it was most probably a bad burn, bad download or bad media/drive pair. This was about a year ago now, I simply used the two hard drive partition method and went from there, you may close this bug if you wish since it is probably unrelated or only mildly related to the libwebcore.so one. The root cause could still be the same but this ticket is old and possibly unfounded.

comment:8 Changed 4 years ago by aldeck

  • Resolution set to invalid
  • Status changed from new to closed

Ok, closing then. Thanks for the update.

comment:9 follow-up: Changed 19 months ago by xsive

I'm getting this error now too also with latest alpha 4 whilst trying to install

comment:10 Changed 19 months ago by xsive

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:11 Changed 19 months ago by xsive

  • Version changed from R1/alpha1 to R1/alpha3

comment:12 in reply to: ↑ 9 Changed 19 months ago by luroh

Replying to xsive:

I'm getting this error now too also with latest alpha 4 whilst trying to install

Please post the exact revision you burned (preferably with a download link). Anyboot or ISO?

comment:13 Changed 16 months ago by jackburton

Happens here too on an old computer I'm doing tests on.
Burned this one:

http://haiku-files.org/haiku/development/haiku-nightly-hrev45122-x86gcc2hybrid-cd.zip

I burned the image to a CD-RW from Windows 7 using CD-Burner XP.

Tried switching hard drive in the test system (since it was very old, I suspected that was the problem), then switched DVD drive, but same error.
Will try burning a new CD.

comment:14 Changed 16 months ago by jackburton

Burned on a new CD-RW and the problem went away. But now the installation hangs a bit later, without any error popping up.

Last edited 16 months ago by jackburton (previous) (diff)

comment:15 Changed 16 months ago by jackburton

Anyway, for me this ticket can be closed, since the problem seemed to be caused by a defective CD.

comment:16 Changed 16 months ago by jackburton

  • Summary changed from Error: Device recalibrate error durning install to Error: Device recalibrate error during install

comment:17 Changed 16 months ago by umccullough

Is there still room for improvement here? Do other OSes attempt to retry the operation a few extra times before finally failing?

I have no clue msyelf, just asking in case there is an enhancement request in here somewhere :)

comment:18 follow-up: Changed 16 months ago by anevilyak

If it's the same CD you're actually running the system off of at the time then it might indeed prove to be a bit fatal, otherwise it should probably just surface back to userland as a read error instead of a panic.

comment:19 in reply to: ↑ 18 Changed 16 months ago by jackburton

Replying to anevilyak:

If it's the same CD you're actually running the system off of at the time then it might indeed prove to be a bit fatal, otherwise it should probably just surface back to userland as a read error instead of a panic.

Yeah, that's what it does, actually. It presents the user with an Alert which says "Error: Device recalibrate error".

Note: See TracTickets for help on using tickets.