Opened 10 years ago

Closed 8 months ago

#4483 closed bug (invalid)

Apple aluminium USB keyboard not recognised

Reported by: thomholwerda Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Apple's aluminium USB keyboard, model no. a1243, is not recognised by Haiku. This keyboard, specifically, which includes two USB 2.0 ports:

http://en.wikipedia.org/wiki/Apple_Keyboard#Apple_Keyboard

...and then model a1243.

I'm running alpha1 revision 33084, natively on a machine with the following specifications:

  • AMD Phenom X4 4x2.2Ghz
  • 4GB RAM
  • IDE HDD
  • SATA DVD drive
  • Foxconn A7GM-S 2.0 motherboard
  • CMI8738-based soundcard

As requested by mmadia, I've included the output of listdev and listusb -v, as well as the syslog.

Attachments (4)

listdev (3.4 KB ) - added by thomholwerda 10 years ago.
listdev output
listusb (9.4 KB ) - added by thomholwerda 10 years ago.
listusb -v output
syslog (86.6 KB ) - added by thomholwerda 10 years ago.
syslog
syslog_daisy (183.9 KB ) - added by thomholwerda 10 years ago.
syslog after daisychaining the keyboard to a usb2.0 hub.

Download all attachments as: .zip

Change History (11)

by thomholwerda, 10 years ago

Attachment: listdev added

listdev output

by thomholwerda, 10 years ago

Attachment: listusb added

listusb -v output

by thomholwerda, 10 years ago

Attachment: syslog added

syslog

comment:1 by mmadia, 10 years ago

related #4067

by thomholwerda, 10 years ago

Attachment: syslog_daisy added

syslog after daisychaining the keyboard to a usb2.0 hub.

comment:2 by mmlr, 10 years ago

Status: newassigned

The OHCI error could easily be the one in #4067. What I find far more worrying in this case though is that it fails over EHCI as well.

comment:3 by kvdman, 10 years ago

I have the same keyboard with my MacPro (desktop). I don't know if this is related, I can tell you that this keyboard worked about 2 months ago with my MacPro and Haiku booted fine. Now, with the official release, both my MacBook (which also booted to the 'installer' - 'desktop' prompt, but the trackpad and keypad didn't work) and MacPro fail to boot up fully, getting stuck on the red rocket. I don't know how to help debugging this, because I can't even boot into safe mode because the keyboards don't work.

comment:4 by kvdman, 10 years ago

One more detail I found. The release in which I reported the keyboard & mouse working, plus Haiku being able to boot on the MacPro (via a CD) was hrev30665.

comment:5 by nielx, 10 years ago

Version: R1 alpha1R1/alpha1

comment:6 by waddlesplash, 10 months ago

Still an issue?

comment:7 by waddlesplash, 8 months ago

Resolution: invalid
Status: in-progressclosed

No reply.

Note: See TracTickets for help on using tickets.