Opened 14 years ago

Closed 13 years ago

Last modified 13 years ago

#45 closed bug (invalid)

Coreutils man-to-docbook leaves trailing command in output file

Reported by: danny@… Owned by: korli
Priority: normal Milestone: R1
Component: Build System Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

In scr/bin/coreutils/man/Jamfile the GenerateChapterXML1 action doesnt finish the cat operation and instead leaves a trailing "EOF \n tail ... ...". This appears to be caused by the indentation of the EOF terminator (I tried removing the tab and it then builds fine). This problem prevents the building of "Shell Tools" in src/documentation/

Change History (8)

comment:1 Changed 14 years ago by bonefish

Owner: changed from bonefish to korli@…

comment:2 Changed 14 years ago by korli

I can't reproduce this bug, could you elaborate on it ? GenerateChapterXML1 action finishes correctly here.

comment:3 Changed 14 years ago by danny@…

Apologies, I didnt state exactly where the problem was. Have a look at objects/ documentation/Shell_Tools/coreutils.xml at the very bottom there's the string "EOF" and a tail command. The jam command will execute properly but the embedded cat wont terminate in the manner intended (although it will finish and appear to complete properly from the scripts viewpoint).

comment:4 Changed 14 years ago by korli

Thanks for this clarification, I had a look at the file objects/x86.release. haiku/documentation/Shell_Tools/coreutils.xml and it doesn't show the symptoms you described. Is there something I should know about your system ? You're on BeOS R5 ?

comment:5 Changed 14 years ago by danny@…

Ahh, I'm running a fairly stock Dano system here (from commandline perspective anyway; I've got the haiku media_server running but I'm pretty sure that's about all the modifications). Im not sure exactly what difference it may make though. Maybe I'll just need to fiddle around a bit and see what makes it work.

comment:6 Changed 13 years ago by korli

Resolution: invalid

comment:7 Changed 13 years ago by korli

Please make sure the bug is still here. There is also a bug with npipefs with large data (noticed with a pci-clean.awk script).

comment:8 Changed 13 years ago by korli

Status: newclosed
Note: See TracTickets for help on using tickets.