Opened 10 years ago

Closed 2 years ago

Last modified 11 months ago

#4509 closed bug (invalid)

Mac mini Intel hangs at boot

Reported by: Jowi Owned by: nobody
Priority: normal Milestone: R1
Component: System Version: R1/alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

  1. Installer works but not with mac aluminum wired keyboard. Correct screen resolution detected @ 1440x900
  1. Installer finishes, ejects CD, reboots.
  1. Boot icons is shown and all icons finishes.
  1. Bluish background is displayed and hand-pointer is shown - but at this stage the computer is hung. Pointer does not move, keyboard does not react.

How to reproduce: Install OS, power cycle computer

To get a functioning keyboard I attached a PS/2 keyboard with a USB adapter. I cannot enter safe mode because the keyboard does not initialize on time for me to press space bar. This computer has only got USB ports.

I'm attaching lspci, lshw and lsusb from Linux if it can help.

Attachments (3)

lspci.txt (15.3 KB) - added by Jowi 10 years ago.
lspci
lshw.txt (16.5 KB) - added by Jowi 10 years ago.
lshw
lsusb.txt (22.7 KB) - added by Jowi 10 years ago.
lsusb

Download all attachments as: .zip

Change History (11)

Changed 10 years ago by Jowi

Attachment: lspci.txt added

lspci

Changed 10 years ago by Jowi

Attachment: lshw.txt added

lshw

Changed 10 years ago by Jowi

Attachment: lsusb.txt added

lsusb

comment:1 Changed 10 years ago by Jowi

Platform: Allx86

comment:2 Changed 10 years ago by kvdman

A bug report has been filed for the aluminum keyboard here:

http://dev.haiku-os.org/ticket/4483

You got further than me. Add the Macbook and MacPro to list of Apple devices that can't boot Haiku with the official R1 release (at least the MacPro worked 4 months ago, see above ticket).

comment:3 Changed 9 years ago by Coldfirex

Able to retest with a recent nightly build?

comment:4 Changed 8 years ago by scottmc

Can you recheck this with a recent Haiku build?

comment:5 Changed 8 years ago by scottmc

Blocking: 7665 added

comment:6 Changed 2 years ago by axeld

Owner: changed from axeld to nobody
Status: newassigned

comment:7 Changed 2 years ago by waddlesplash

Resolution: invalid
Status: assignedclosed

No reply. Closing.

comment:8 Changed 11 months ago by waddlesplash

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.