Opened 10 years ago

Closed 10 years ago

#4544 closed bug (invalid)

"Failed to load OS" error

Reported by: jedie Owned by: axeld
Priority: normal Milestone: R1
Component: System/Boot Loader Version: R1/alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I get the "Failed to load OS" error on my ASUS A8J. But the USB-Stick works well on a other PC. I can only Boot the Live CD on the ASUS A8J, this works fine.

Change History (9)

comment:1 Changed 10 years ago by jedie

Some data: BIOS Date: 10/11/06 Ver: A8JAS.212 (This is the latest available BIOS version) CPU: Intel T1300

comment:2 Changed 10 years ago by stippi

"Failed to load OS" seems to be a message from the BIOS. I wouldn't trust a computer from 2006 to boot off of USB reliably. Have you tried any other operating systems to boot from a USB stick on this computer?

comment:3 Changed 10 years ago by jedie

No, i found the string "Failed to load OS" on the disk. So i think it's a part of the Haiku boot loader.

I installed SystemRescueCd on the same USB-stick and i can boot this one...

comment:4 Changed 10 years ago by stippi

Ok, that makes sense. At this stage, I believe the Haiku loader would access the disk via the BIOS still. There seems to be a problem with that, but I am not qualified to ask further info, maybe someone else can chime in... :-)

comment:5 Changed 10 years ago by marcusoverhagen

"Failed to load OS" is printed by the stage 1 bootloader. I have a similar problem, #4408.

comment:6 Changed 10 years ago by jedie

OK, now it works.

I used the windows tool "Haiku On A Stick" http://modeen.se/HaikuOnAstick.htm and used the R33149 GCC4 image.

After this i run "makebootable" on a Haiku system.

and now i can boot from the USB Stick ;)

Should we close this ticked?

comment:7 Changed 10 years ago by stippi

Hm. While it does make it sound like you made a "user error" the first time around, you also said that the very same stick booted on another system. Did you mean that the same physical stick booted with another installation of Haiku, or did you mean that the stick with the very same installation booted on another system but not on this one? If you talked about two different installations, we could close this ticket as invalid, otherwise it wouldn't be satisfactorily solved yet. :-)

comment:8 Changed 10 years ago by jedie

In the first test, is used the "normal" Alpha1 R33109 Now, i used R33149.

Don't know if the revision works now or if my stick wasn't right "installed" on the first test.

Think we can close this ticked as invalid.

comment:9 Changed 10 years ago by mmlr

Resolution: invalid
Status: newclosed

It sounds like not properly installed. Most probably installed to a partition instead of the whole disk and not made bootable afterwards.

Note: See TracTickets for help on using tickets.