Opened 10 years ago

Closed 8 years ago

Last modified 11 months ago

#4548 closed bug (invalid)

At boot: "PANIC: ref count of B_KEEP_LOADED module bus_manager s/pci/v1 dropped to 01"

Reported by: nirbheek Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

This happens when booting from an alpha1 RAW image cat-ed to a partition (and makebootable-ed). None of the safe modes help. The output of debug output to console while booting is attached below in the form of jpeg photos.

I don't know what else you'd want to know, but this is hardware-specific so here's my lspci:
---
# lspci
00:00.0 Host bridge: ATI Technologies Inc Radeon Xpress 200 Host Bridge (rev 01)
00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:11.0 IDE interface: ATI Technologies Inc IXP SB400 Serial ATA Controller (rev 80)
00:12.0 IDE interface: ATI Technologies Inc IXP SB400 Serial ATA Controller (rev 80)
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller (rev 80)
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 81)
00:14.1 IDE interface: ATI Technologies Inc IXP SB400 IDE Controller (rev 80)
00:14.2 Audio device: ATI Technologies Inc IXP SB4x0 High Definition Audio Controller (rev 01)
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge (rev 80)
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge (rev 80)
01:05.0 VGA compatible controller: ATI Technologies Inc RC410 [Radeon Xpress 200]
02:02.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

Attachments (1)

img_2165.jpg (109.0 KB) - added by nirbheek 10 years ago.
Final page of debug output showing kernel panic

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by nirbheek

Attachment: img_2165.jpg added

Final page of debug output showing kernel panic

comment:1 Changed 10 years ago by nirbheek

Attached above is the final page of the debug output, the earlier pages are here: http://dev.gentoo.org/~nirbheek/files/haiku_crash/

If you want me to attach those as well, please let me know.

comment:2 in reply to:  1 Changed 10 years ago by umccullough

Replying to nirbheek:

If you want me to attach those as well, please let me know.

It's always a good idea to do so, in the event that this needs to be reviewed again someday in the future and the links are broken.

comment:3 Changed 10 years ago by mmlr

Can you please run the "sc" command at the kernel debugger and post a picture of that as well?

comment:4 Changed 8 years ago by scottmc

Can you recheck this with a recent Haiku build?

comment:5 Changed 8 years ago by scottmc

Blocking: 7665 added

comment:6 Changed 8 years ago by nirbheek

I'm sorry, but I don't have access to the hardware I saw this bug on anymore, so I can't recheck this.

Apologies for not being more helpful.

comment:7 Changed 8 years ago by korli

Resolution: invalid
Status: newclosed

alpha1 is dated anyway.

comment:8 Changed 11 months ago by waddlesplash

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.