Opened 10 years ago

Closed 15 months ago

#4553 closed bug (fixed)

Installer halts after copying only a few files

Reported by: chrisjam82 Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Drivers/Disk Version: R1/alpha1
Keywords: Cc: meanwhile@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

When trying to install Haiku to the hard disk from the Haiku Installer CD it appears to start correctly but after copying only a few files (this varies from 4 to ~140, never more than that) it halts and the hard drive light stays lit until a restart. The system becomes unresponsive also; sometimes it responds to the 'Stop' button and show the Shutdown dialog, other times it doesn't.

When a 2nd Hard drive was installed in the PC it halted but also the debugger command line would appear at the top of the screen and the system would be completely unresponsive.

Similar system unresponsiveness and the lit hard drive light were seen when the system was booted from the CD and then the hard drive partition was mounted.

Have also tried to boot with DMA disabled and with many of the other options disabled, such as ACPI and disallow BIOS calls, but these didn't affect anything.

Attachments (4)

installprogresshalt.txt (61.5 KB ) - added by Meanwhile 10 years ago.
installprogress.txt (55.1 KB ) - added by Meanwhile 10 years ago.
System2.jpg (79.0 KB ) - added by chrisjam82 10 years ago.
listdevticket4553.txt (14.4 KB ) - added by Meanwhile 10 years ago.
listdev

Download all attachments as: .zip

Change History (15)

comment:1 by chrisjam82, 10 years ago

Sorry forgot the PC details:

Intel 82801DB Ultra ATA Controller HD: Maxtor 6L020J1 CPU: Pentium 4 2.0GHz

I'll include a screenshot from Windows Device Manager.

comment:2 by stippi, 10 years ago

Component: SystemDrivers/Disk
Owner: changed from axeld to marcusoverhagen

Thanks for the feedback and sorry it doesn't work on your hardware! Since it works as far as copying a few files, it looks like a problem with error recovery in the ATA stack, or perhaps some interference with another piece of hardware on the same interrupt line. Do you have a BIOS option "Plug'n'Play OS installed"? It should be off/no for Haiku to have a better chance of working. But I am just poking in the dark. When you see the debugger message, please also type "bt" at the prompt and it would be great if you could take photos of your screen, scale them down so that they are just still readable and attach them to this ticket. Thanks a lot!

by Meanwhile, 10 years ago

Attachment: installprogresshalt.txt added

by Meanwhile, 10 years ago

Attachment: installprogress.txt added

comment:3 by Meanwhile, 10 years ago

Same thing here. Its serial debug output is 'installprogresshalt.txt', reporting events on the partition where installation of files had begun (but halted). The other output (called 'installprogress') is of an installation attempt on another partition of the same HDD, but there it went into KDL, possibly for unrelated reasons.

comment:4 by Meanwhile, 10 years ago

(Plug 'n Play had been switched off in the BIOS in both cases)

comment:5 by Meanwhile, 10 years ago

Cc: meanwhile@… added

comment:6 by chrisjam82, 10 years ago

Hia Stippi,

Thanks for your feedback. I tried it again with P'n'P OS Disabled in BIOS but it didn't make any difference. Also, since I had the secondary drive removed from the PC, the debugger doesn't appear and it remains somewhat responsive (pressing STOP does respond after a minute and Ctrl + Alt + Del sometimes brings up the dialog, although it usually will not actually restart the machine).

I also totally removed my Ext2 & swap partitions and just install Haiku onto a new larger primary partition, but again this didn't make any difference to the outcome.

I haven't had much time to try more, but I'll re-connect my 2nd harddrive, which will probably bring up the debugger console and I'll use my PS/2 keyboard to get the out put from it.

I'll try and upload the screenshot of my PC's device manager (it wouldn't upload here when I tried last time).

Kind regards, Chris.

P.S. Awesome effort chaps and ladies, can't believe Haiku's made it so far. Would love to help out more, but I've not really got the time. If I can do end-user testing I'm more than happy. Love to get an install on my 2nd PC and use it as the main OS!

by chrisjam82, 10 years ago

Attachment: System2.jpg added

by Meanwhile, 10 years ago

Attachment: listdevticket4553.txt added

listdev

comment:7 by Meanwhile, 10 years ago

Just adding that -in my case at least- it doesn't seem to be a problem of the HDD in itself, because of this: I got Haiku installed on a HDD on one PC, then took it out and installed it into another PC, where it (and the Haiku install on it) worked fine. This was done because I couldn't get Haiku installed on the original HDD of the 'receiving PC' (because of this bug). After that I had to -for some other reason- wipe this HDD (with Haiku on it), and from then on couldn't get Haiku installed on it again (also because of the bug described here). So to me it seems like a combination of Haiku, the PC and the HDD. BeOS Max let itself be installed on that HDD-PC combination, though it crashes each time when loading the Desktop. (listdev. attached)

comment:8 by chrisjam82, 10 years ago

I reconnected my second hard-drive to make the debugger prompt appear as it did originally so I could interrogate it to get more information for you guys. However, this time the installer progressed fully! The difference was that the Plug 'n' Play OS option was disabled in the BIOS. Still, not all is well as I can't get it to boot into haiku on the HDD. I've tried both from the CD (HDD partition not there to select) and from GRUB (just shows the boot menu, again no partition) but I think that's a separate issue to this one.

If there is anything anyone would like me to try in relation to my install experience, I'd be more than happy to test.

comment:9 by Meanwhile, 10 years ago

Haiku r1a1 finally installed fine here. After reading ticket #4050 and noticing that chrisjam82 tried to install on a PC with 2 HDD's, (just like I had been trying) I disconnected one of the two and after that installation on the remaining HDD went fine!

Recommended booting solution: I made sure to install Haiku on a partitioned HDD and installed BeOS on another partition of it. BeOS may be not very useful any more, if it weren't for the option (provided at the end of the BeOS installation) to install Bootman, enabling access to Haiku in a nice, clean BeOS fashion (I guess much like Haiku will do in the future).

comment:10 by cocobean, 15 months ago

hrev52017 reviewed. Based on users' feedback in this ticket with resolution, we can close this ticket.

comment:11 by diver, 15 months ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.