Opened 10 years ago

Closed 5 months ago

#4552 closed bug (fixed)

Networking Dies on Haiku R1Alpha1

Reported by: NathanP Owned by: nobody
Priority: normal Milestone: R1
Component: Network & Internet Version: R1/alpha1
Keywords: Cc: fredrik.holmqvist@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Hello! Long time listener, first time caller.

I've been experiencing some issues with Haiku involving networking just dieing on me when two or more applications access the Internet.

If I open an application like Vision, I can connect to Freenode and access #Haiku and talk with no issues. But if then I open up Bezilla and go to Google.com, my network will suddenly stop shortly after and applications fail to connect to the Internet.

I am using a Dell Inspiron 9300 using a Broadcom 440x 10/100 Ethernet card.

I used to alleviate this issue by replacing the Broadcom driver from Haiku with ZETA's, but this no longer works.

Attachments (1)

syslog (61.9 KB) - added by NathanP 10 years ago.
My Haiku's syslog file.

Download all attachments as: .zip

Change History (11)

Changed 10 years ago by NathanP

Attachment: syslog added

My Haiku's syslog file.

comment:1 Changed 10 years ago by tqh

This is exactly what happens with rtl8169 as well, reported in #2801.

comment:2 Changed 10 years ago by tqh

Cc: fredrik.holmqvist@… added

comment:3 Changed 10 years ago by NathanP

Edit: How foolish of me. This happens regardless on application. About ten seconds after booting-up, networking just dies.

comment:4 Changed 10 years ago by pulkomandy

May (or may not) be related to http://dev.haiku-os.org/ticket/4239 Same symptoms, different hardware.

comment:5 Changed 10 years ago by phoudoin

This seem interesting:

1098	KERN: /dev/net/broadcom440x/0: media change, media 0x900026 quality 1000 speed 10000
1099	DAEMON 'DHCP': DHCP timeout shift: 4 secs (try 0)

Seems the Broadcom PHY report a media change right before timeout starts.

comment:6 Changed 8 years ago by Coldfirex

Still an issue with a recent build?

comment:7 Changed 8 years ago by deejam

I'm pretty sure this is the same problem as reported in many other tickets. Ticket #7346 pinpoints the problem and what the solution to the problem is. Fixing this will close a lot of tickets that has been reported in different ways. #7380 (closed as duplicate of #7346) has some good information about how to spot and reproduce the problem.

comment:8 Changed 2 years ago by axeld

Owner: changed from axeld to nobody
Status: newassigned

comment:9 Changed 8 months ago by waddlesplash

All three of those tickets have been fixed; can you retest this one?

comment:10 Changed 5 months ago by waddlesplash

Resolution: fixed
Status: assignedclosed

No reply, assuming indeed fixed.

Note: See TracTickets for help on using tickets.