Opened 10 years ago

Closed 10 years ago

#4566 closed bug (duplicate)

Inconsistent search dirs between gcc2 and gcc4.

Reported by: maxime.simon Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/alpha1
Keywords: Cc:
Blocked By: #4565 Blocking:
Has a Patch: no Platform: All

Description

The gcc search directories aren't consistent between gcc2 and gcc4 in the hybrid image, especially for the libraries path.

Also, the gcc4 libraries path includes some /usr/… and no /boot/common/…

~> gcc --version
gcc (GCC) 4.3.3
Copyright (C) 2008 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.}}}

~> gcc -print-search-dirs
install: /boot/develop/abi/x86/gcc4/tools/gcc-4.3.3-haiku-090629/bin/../lib/gcc/i586-pc-haiku/4.3.3/
programs: =/boot/develop/abi/x86/gcc4/tools/gcc-4.3.3-haiku-090629/bin/../libexec/gcc/i586-pc-haiku/4.3.3/:/boot/develop/abi/x86/gcc4/tools/gcc-4.3.3-haiku-090629/bin/../libexec/gcc/:/usr/libexec/gcc/i586-pc-haiku/4.3.3/:/usr/libexec/gcc/i586-pc-haiku/:/usr/lib/gcc/i586-pc-haiku/4.3.3/:/usr/lib/gcc/i586-pc-haiku/:/boot/develop/abi/x86/gcc4/tools/gcc-4.3.3-haiku-090629/bin/../lib/gcc/i586-pc-haiku/4.3.3/../../../../i586-pc-haiku/bin/i586-pc-haiku/4.3.3/:/boot/develop/abi/x86/gcc4/tools/gcc-4.3.3-haiku-090629/bin/../lib/gcc/i586-pc-haiku/4.3.3/../../../../i586-pc-haiku/bin/:/usr/ccs/bin/i586-pc-haiku/4.3.3/:/usr/ccs/bin/
libraries: =/boot/develop/abi/x86/gcc4/tools/gcc-4.3.3-haiku-090629/bin/../lib/gcc/i586-pc-haiku/4.3.3/:/boot/develop/abi/x86/gcc4/tools/gcc-4.3.3-haiku-090629/bin/../lib/gcc/:/boot/develop/abi/current/library-paths/common/i586-pc-haiku/4.3.3/:/boot/develop/abi/current/library-paths/common/:/boot/develop/lib/x86/i586-pc-haiku/4.3.3/:/boot/develop/lib/x86/:/usr/lib/gcc/i586-pc-haiku/4.3.3/:/boot/develop/abi/x86/gcc4/tools/gcc-4.3.3-haiku-090629/bin/../lib/gcc/i586-pc-haiku/4.3.3/../../../../i586-pc-haiku/lib/i586-pc-haiku/4.3.3/:/boot/develop/abi/x86/gcc4/tools/gcc-4.3.3-haiku-090629/bin/../lib/gcc/i586-pc-haiku/4.3.3/../../../../i586-pc-haiku/lib/:/usr/ccs/lib/i586-pc-haiku/4.3.3/:/usr/ccs/lib/:/boot/develop/abi/x86/gcc4/tools/gcc-4.3.3-haiku-090629/bin/../lib/gcc/i586-pc-haiku/4.3.3/../../../i586-pc-haiku/4.3.3/:/boot/develop/abi/x86/gcc4/tools/gcc-4.3.3-haiku-090629/bin/../lib/gcc/i586-pc-haiku/4.3.3/../../../:/lib/i586-pc-haiku/4.3.3/:/lib/:/usr/lib/i586-pc-haiku/4.3.3/:/usr/lib/


~> gcc --version
2.95.3-haiku-090629

~> gcc -print-search-dirs
install: /boot/develop/tools/gnupro/lib/gcc-lib/i586-pc-haiku/2.95.3-haiku-090629/
programs: /boot/develop/tools/gnupro/lib/gcc-lib/i586-pc-haiku/2.95.3-haiku-090629/:/boot/develop/tools/gnupro/lib/gcc-lib/i586-pc-haiku/:/boot/develop/tools/gnupro/i586-pc-haiku/bin/i586-pc-haiku/2.95.3-haiku-090629/:/boot/develop/tools/gnupro/i586-pc-haiku/bin/
libraries: /boot/develop/abi/current/library-paths/common/i586-pc-haiku/2.95.3-haiku-090629/:/boot/develop/abi/current/library-paths/common/:/boot/develop/lib/x86/i586-pc-haiku/2.95.3-haiku-090629/:/boot/develop/lib/x86/:/boot/develop/tools/gnupro/lib/gcc-lib/i586-pc-haiku/2.95.3-haiku-090629/:/boot/develop/tools/gnupro/i586-pc-haiku/lib/i586-pc-haiku/2.95.3-haiku-090629/:/boot/develop/tools/gnupro/i586-pc-haiku/lib/:/boot/develop/tools/gnupro/lib/i586-pc-haiku/2.95.3-haiku-090629/:/boot/develop/tools/gnupro/lib/

Change History (1)

comment:1 Changed 10 years ago by anevilyak

Blocked By: 4565 added
Resolution: duplicate
Status: newclosed

Duplicate of #4565.

Note: See TracTickets for help on using tickets.