Opened 10 years ago

Closed 4 years ago

#4565 closed bug (fixed)

Inconsistent search dirs between gcc2 and gcc4.

Reported by: maxime.simon Owned by: zooey
Priority: normal Milestone: R1
Component: - General Version: R1/alpha1
Keywords: Cc: joe.prostko+haiku@…
Blocked By: Blocking: #4566
Has a Patch: no Platform: All

Description

The gcc search directories aren't consistent between gcc2 and gcc4 in the hybrid image, especially for the libraries path.

Also, the gcc4 libraries path includes some /usr/… and no /boot/common/…

~> gcc --version
gcc (GCC) 4.3.3
Copyright (C) 2008 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.}}}

~> gcc -print-search-dirs
install: /boot/develop/abi/x86/gcc4/tools/gcc-4.3.3-haiku-090629/bin/../lib/gcc/i586-pc-haiku/4.3.3/
programs: =/boot/develop/abi/x86/gcc4/tools/gcc-4.3.3-haiku-090629/bin/../libexec/gcc/i586-pc-haiku/4.3.3/:/boot/develop/abi/x86/gcc4/tools/gcc-4.3.3-haiku-090629/bin/../libexec/gcc/:/usr/libexec/gcc/i586-pc-haiku/4.3.3/:/usr/libexec/gcc/i586-pc-haiku/:/usr/lib/gcc/i586-pc-haiku/4.3.3/:/usr/lib/gcc/i586-pc-haiku/:/boot/develop/abi/x86/gcc4/tools/gcc-4.3.3-haiku-090629/bin/../lib/gcc/i586-pc-haiku/4.3.3/../../../../i586-pc-haiku/bin/i586-pc-haiku/4.3.3/:/boot/develop/abi/x86/gcc4/tools/gcc-4.3.3-haiku-090629/bin/../lib/gcc/i586-pc-haiku/4.3.3/../../../../i586-pc-haiku/bin/:/usr/ccs/bin/i586-pc-haiku/4.3.3/:/usr/ccs/bin/
libraries: =/boot/develop/abi/x86/gcc4/tools/gcc-4.3.3-haiku-090629/bin/../lib/gcc/i586-pc-haiku/4.3.3/:/boot/develop/abi/x86/gcc4/tools/gcc-4.3.3-haiku-090629/bin/../lib/gcc/:/boot/develop/abi/current/library-paths/common/i586-pc-haiku/4.3.3/:/boot/develop/abi/current/library-paths/common/:/boot/develop/lib/x86/i586-pc-haiku/4.3.3/:/boot/develop/lib/x86/:/usr/lib/gcc/i586-pc-haiku/4.3.3/:/boot/develop/abi/x86/gcc4/tools/gcc-4.3.3-haiku-090629/bin/../lib/gcc/i586-pc-haiku/4.3.3/../../../../i586-pc-haiku/lib/i586-pc-haiku/4.3.3/:/boot/develop/abi/x86/gcc4/tools/gcc-4.3.3-haiku-090629/bin/../lib/gcc/i586-pc-haiku/4.3.3/../../../../i586-pc-haiku/lib/:/usr/ccs/lib/i586-pc-haiku/4.3.3/:/usr/ccs/lib/:/boot/develop/abi/x86/gcc4/tools/gcc-4.3.3-haiku-090629/bin/../lib/gcc/i586-pc-haiku/4.3.3/../../../i586-pc-haiku/4.3.3/:/boot/develop/abi/x86/gcc4/tools/gcc-4.3.3-haiku-090629/bin/../lib/gcc/i586-pc-haiku/4.3.3/../../../:/lib/i586-pc-haiku/4.3.3/:/lib/:/usr/lib/i586-pc-haiku/4.3.3/:/usr/lib/


~> gcc --version
2.95.3-haiku-090629

~> gcc -print-search-dirs
install: /boot/develop/tools/gnupro/lib/gcc-lib/i586-pc-haiku/2.95.3-haiku-090629/
programs: /boot/develop/tools/gnupro/lib/gcc-lib/i586-pc-haiku/2.95.3-haiku-090629/:/boot/develop/tools/gnupro/lib/gcc-lib/i586-pc-haiku/:/boot/develop/tools/gnupro/i586-pc-haiku/bin/i586-pc-haiku/2.95.3-haiku-090629/:/boot/develop/tools/gnupro/i586-pc-haiku/bin/
libraries: /boot/develop/abi/current/library-paths/common/i586-pc-haiku/2.95.3-haiku-090629/:/boot/develop/abi/current/library-paths/common/:/boot/develop/lib/x86/i586-pc-haiku/2.95.3-haiku-090629/:/boot/develop/lib/x86/:/boot/develop/tools/gnupro/lib/gcc-lib/i586-pc-haiku/2.95.3-haiku-090629/:/boot/develop/tools/gnupro/i586-pc-haiku/lib/i586-pc-haiku/2.95.3-haiku-090629/:/boot/develop/tools/gnupro/i586-pc-haiku/lib/:/boot/develop/tools/gnupro/lib/i586-pc-haiku/2.95.3-haiku-090629/:/boot/develop/tools/gnupro/lib/

Change History (9)

comment:1 Changed 10 years ago by zooey

Owner: changed from axeld to zooey

comment:2 Changed 10 years ago by anevilyak

Blocking: 4566 added

(In #4566) Duplicate of #4565.

comment:3 Changed 10 years ago by jprostko

Cc: joe.prostko+haiku@… added

comment:4 Changed 10 years ago by zooey

Status: newassigned

Hm, when comparing the library paths of the two gccs, you'll see that both actually specify /boot/develop/abi/current/library-paths/common, which is a link to /boot/common/lib.

So both gcc2 and gcc4 should find libraries in /boot/common/lib automatically. If gcc4 doesn't do that for you, please check if the link from /boot/develop/abi/current/library-paths/common to /boot/common/lib is intact (after activating gcc4 with setgcc).

comment:5 Changed 10 years ago by maxime.simon

Actually with gcc2, /boot/develop/abi/current/library-paths/common is linked to /boot/common/lib, but with gcc4 it's linked to /boot/common/lib/gcc4.

~> setgcc x86 gcc2
~> ll /boot/develop/abi/current/library-paths/common
lrwxrwxrwx 1 user root 16 Sep 12 22:13 /boot/develop/abi/current/library-paths/common -> /boot/common/lib
~> setgcc x86 gcc4
~> ll /boot/develop/abi/current/library-paths/common
lrwxrwxrwx 1 user root 21 Sep 12 22:16 /boot/develop/abi/current/library-paths/common -> /boot/common/lib/gcc4

comment:6 Changed 9 years ago by zooey

Status: in-progressassigned

comment:7 Changed 5 years ago by diver

Is this still an issue?

comment:8 Changed 5 years ago by waddlesplash

Don't think so, looks like PM fixed it.

comment:9 Changed 4 years ago by waddlesplash

Resolution: fixed
Status: assignedclosed

Confirmed fixed.

Note: See TracTickets for help on using tickets.