Opened 10 years ago

Closed 10 years ago

#4579 closed bug (duplicate)

possible jam -j2 error

Reported by: mmadia Owned by: bonefish
Priority: normal Milestone: R1
Component: Build System Version: R1/alpha1
Keywords: Cc:
Blocked By: #4091 Blocking:
Has a Patch: no Platform: All

Description

A few weeks ago, I started using -j2 on the FreeBSD BOM machine building trunk/.. jam clean is performed after every cycle and xattrs is enabled. The following error will randomly affect a single jam target for a single arch. The others will build successfully. I've since replicated it on a 2nd FreeBSD BOM machine, also building trunk/.

...failed Cc <haiku>/generated.x86gcc4hybrid/objects/haiku/x86/release/bin/bash/builtins/builtins.o ...

I'm switching back to -j1 for now and will monitor for the error. Full log attached.

Attachments (1)

r33184-x86gcc4hybrid-jam-haiku-alpha.image.log (31.1 KB) - added by mmadia 10 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 10 years ago by pulkomandy

Also happens for me using -j2 under linux/gcc4 from time to time. Building a second time makes it pass.

comment:2 Changed 10 years ago by bonefish

Blocked By: 4091 added
Resolution: duplicate
Status: newclosed

Duplicate of #4091 (cf. the last comments). Appears to be a jam problem.

Note: See TracTickets for help on using tickets.