Opened 10 years ago

Closed 10 years ago

#4578 closed bug (duplicate)

U3 USB Stick not mounting fat when inserting second time

Reported by: leszek Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/alpha1
Keywords: Cc:
Blocked By: #4587 Blocking:
Has a Patch: no Platform: x86

Description

When I insert an U3 USB Stick right after the boot of Haiku, it recognizes the U3 virtual CD-ROM drive and the FAT part of the stick. When unmounting both and then reinserting the stick it only mounts and recognizes the U3 virtual CD-ROM part. A reboot is necessary to make it recognize. I think its also very strange that even after removing the usb stick the /dev/disk/usb/1/ folder which got created upon inserting the stick the first time, does not got deleted. Perhaps this might be causing the bug. (/dev/disk/usb/0 is my internal card reader, for the ones who are wondering why the usb stick is 1)

Hardware is an eeePC 701 4G running on Haiku r1alpha1 . The USB Stick is a SanDisk Cruzer Micro 4G

Change History (7)

comment:1 by umccullough, 10 years ago

I saw the same thing recently with my kingston traveler g2 stick(s) (which previously had the issue mentioned in #4135)

I think they no long exhibit the crash in #4135 (which I'll update later), but after removing them and reinserting them, they no longer are recognized. I have 4 of them, and no matter which one I put in, neither of them are recognized after the first one has been removed. Other sticks continue to work.

Could this also be related to media change events?

comment:2 by mmadia, 10 years ago

possibly related to #4587 ?

comment:3 by leszek, 10 years ago

Hmm... might be random but after removing the usb stick and trying to remove the /dev/disk/usb/1 directory within tracker (it cannot remove everything or anything, I am not quite sure) and plugging in the usb stick, everything gets detected fine. Somehow strange. I will investigate it further with current build 33207.

comment:4 by leszek, 10 years ago

Ok the last post was a random behavior that has nothing to do with what I did. But I still have no clue why that happened, because syslog seems to be same and listusb shows no changes. I tested this also on hrev33206 which shows the same behavior.

comment:5 by leszek, 10 years ago

I found a another random behavior. When pulling the stick out before unmounting (after a sync and everything got written on it, nice led backlight showing if writting or sleeping) there might be a big chance that after this and reputting the stick in again, the partitions will be recognized again.

I am guessing the problem has something to do which partition table on the stick gets recognized sooner. If its the U3 virtual CD-ROM part then the FAT partition is ignored and not even mountable. If its the FAT partition it is getting mount and then the U3 virtual CD drive gets recognized.

comment:6 by leszek, 10 years ago

Seems to be fixed. At least in hrev33396 everything is working fine no matter how often I put the stick in :)

comment:7 by mmlr, 10 years ago

Blocked By: 4587 added
Resolution: duplicate
Status: newclosed

I'm going to close this one as a duplicate of #4587. If it actually is a duplicate then that it worked was pure chance.

Note: See TracTickets for help on using tickets.