Opened 10 years ago

Closed 10 years ago

#4585 closed bug (fixed)

heap grower PANIC

Reported by: mvfranz Owned by: mmlr
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

While building gcc 4.3.3 on R1 Alpha the following kernel panic occurred.

PANIC: ASSERT FAILED(/BOM/haiku/haiku/src/system/kernel/vm/vm_page_.cpp:1842): sReservedPages >= count

I looked at the backtrace but it looked like it was in the debugger and did not tell me more information than the like of the kernel code that caused the problem.

Attachments (1)

HaikuPanic_2rev.jpg (443.8 KB ) - added by mvfranz 10 years ago.
Kernel Panic backtrace -second time

Download all attachments as: .zip

Change History (7)

comment:1 by mmlr, 10 years ago

Likely another instance of the address space overflow. If this is the case it should be fixed in the trunk. A backtrace would be helpful to determine where exactly it failed to be able to confirm the likelihood of it being the overflow. Just to make sure btw, you realize that GCC4 is already installed in the alpha release and you don't have to build it yourself?

comment:2 by mvfranz, 10 years ago

I wrote down some of the backtrace, but it was very tedious. I did a quick search to see if there was way to get the bt off my system, but did not find a way. Next time I will take a picture.

I know gcc4 is on the system. I am testing some stuff and want to ensure that I can build gcc 4.3.3. The build seems to create a good stress test for the system.

comment:3 by anevilyak, 10 years ago

Owner: changed from axeld to mmlr

You can either take a picture or get it across serial if you have the requisite cable, ports and a second machine.

by mvfranz, 10 years ago

Attachment: HaikuPanic_2rev.jpg added

Kernel Panic backtrace -second time

comment:4 by mvfranz, 10 years ago

Since I have been using Haiku pretty much every day for development I have found that this happens every day. If I let my pc run over night there is a 100% chance that I will have this PANIC in the morning. This happens on both a VMware image and my real hardware.

What is interesting as nothing is running at the time. My builds have finished and Haiku is just sitting idle.

comment:5 by mmlr, 10 years ago

Does this still happen? If it was caused by address space overflows it should be fixed for quite some time now.

comment:6 by mmlr, 10 years ago

Resolution: fixed
Status: newclosed

For lack of feedback I'm going to close this under the assumption that it was an address space overflow which was fixed in the meantime, please reopen or create a new ticket if seen again.

Note: See TracTickets for help on using tickets.