Opened 10 years ago

Closed 7 years ago

#4607 closed bug (duplicate)

MediaPlayer Locks Up if Services Restarted

Reported by: sikosis Owned by: nobody
Priority: normal Milestone: R1
Component: Applications/MediaPlayer Version: R1/Development
Keywords: Cc: mdisreali@…
Blocked By: #1955 Blocking:
Has a Patch: no Platform: All

Description

When playing a video in MediaPlayer, and then you go into the Media preferences and Restart the Media Services -- this causes MediaPlayer to lock up and consume 100% CPU and requires force closing.

Any chance of making MediaPlayer stop or close if the services are restarted whilst it's playing ?

Change History (7)

comment:1 Changed 10 years ago by jackburton

BTW do we really need to keep the "Restart media server" button ?

comment:2 Changed 10 years ago by stippi

I am not convinced that the media_server does all the necessary resource tracking, as long as it doesn't do this, the button is useful. :-)

As for MediaPlayer, it's supposed to detect and survive this situation, IIRC. So the bug is perfectly valid.

comment:3 Changed 9 years ago by marcusoverhagen

Owner: changed from marcusoverhagen to nobody
Status: newassigned

comment:4 in reply to:  1 ; Changed 9 years ago by Disreali

Cc: mdisreali@… added
Version: R1/alpha1R1/Development

Still an issue on hrev39011.

Replying to jackburton:

BTW do we really need to keep the "Restart media server" button ?

Yes, how else is a normal user supposed to re-start the media_server if it fails? Not everyone is comfortable with the command line. Besides, it is so much easier and quicker to just use the button in the preflet.

comment:5 Changed 9 years ago by Disreali

duplicate of ticket:1955

comment:6 in reply to:  4 Changed 9 years ago by anevilyak

Replying to Disreali:

Yes, how else is a normal user supposed to re-start the media_server if it fails? Not everyone is comfortable with the command line. Besides, it is so much easier and quicker to just use the button in the preflet.

If you start the media preflet after the server has crashed, the preflet will offer to start it for you, no command line needed. His point was that unlike R5's media_server, ours can node monitor and pick up changes on the fly, so manual restarts are no longer needed to detect new stuff.

Last edited 9 years ago by anevilyak (previous) (diff)

comment:7 Changed 7 years ago by diver

Blocked By: 1955 added
Component: Audio & VideoApplications/MediaPlayer
Resolution: duplicate
Status: assignedclosed
Note: See TracTickets for help on using tickets.