Opened 11 years ago

Last modified 9 months ago

#1955 in-progress bug

Media Player won't respond after Restarting Media Server

Reported by: scottmc Owned by: stippi
Priority: normal Milestone: R1
Component: Applications/MediaPlayer Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #4607
Has a Patch: no Platform: All

Description

I tried to see what would happen when playing a song with Media Player and then restarting the Media Server during the song. The result is that after the Media Server is restarted that Media Player refuses to resume or shut-down. VLC however will resume if you press the play button. I did a quick search but didn't find any other tickets that matched. Tested on hrev24493

Attachments (7)

bt.JPG (40.4 KB) - added by Coldfirex 8 years ago.
bt
gdb.JPG (151.4 KB) - added by Coldfirex 8 years ago.
gdb
screenshot1.png (93.1 KB) - added by vidrep 2 years ago.
screenshot2.png (93.3 KB) - added by vidrep 2 years ago.
screenshot3.png (119.6 KB) - added by vidrep 2 years ago.
screenshot4.png (116.5 KB) - added by vidrep 2 years ago.
syslog (141.9 KB) - added by vidrep 2 years ago.

Download all attachments as: .zip

Change History (18)

comment:1 Changed 11 years ago by stippi

Owner: changed from marcusoverhagen to stippi
Status: newassigned

Yes, this is a known problem with MediaKit applications. I have once written an article about it. Don't know when I will have the time, but I can try and look into this.

comment:2 Changed 11 years ago by scottmc

Not sure if this is related or not, but while playing a song .wav file on media player I hit f12 to drop to kdl to see something else and when i left kdl mediaplayer was frozen. I did a ctrl-alt-del and killed off media player and then reopened it and it still wouldn't play. So closed it again and restarted media server and then media player worked fine again. Not reporting this as a bug as I'm not sure that media server should/would still work after dropping into and out of kdl, just thought it might be related this this bug report.

comment:3 Changed 9 years ago by scottmc

Nice work on the Media Player, it is shaping up nicely, but this one is still with us in hrev38594.

comment:4 Changed 9 years ago by stippi

Component: Audio & VideoApplications/MediaPlayer

I know.

comment:5 Changed 8 years ago by diver

Version: R1/pre-alpha1R1/Development

comment:6 Changed 8 years ago by Coldfirex

MediaPlayer no longer freezes when restating the services. I am allowed to close the player, of course then it crashes. I am able to reopen audio/video correctly afterward though. gbd and bt attached. hrev39551 gcc2hybrid virtualbox 3.2.10 FYI, Ticket #4607 is a duplicate.

Changed 8 years ago by Coldfirex

Attachment: bt.JPG added

bt

Changed 8 years ago by Coldfirex

Attachment: gdb.JPG added

gdb

comment:7 Changed 7 years ago by halilpk

Haiku revision: hrev42211 not a bug. When you restart Media Server during the playing media file there was an error message and it closes the media player but you can't resume . System: Haiku hrev1-alpha3 on VMware workstation 8 on windows 7 32 bit

comment:8 Changed 7 years ago by diver

Blocking: 4607 added

comment:9 Changed 2 years ago by vidrep

Tested with hrev50677 x86_gcc2 Play a mp3 file with MediaPlayer Media Settings is showing Audio settings, Audio mixer, and HD Audio (screenshot1.png) Restart Media Services while file is playing The file cannot be restarted and HD Audio is now missing from Media Settings (screenshot2.png) Only a reboot will bring back normal functions.

Changed 2 years ago by vidrep

Attachment: screenshot1.png added

Changed 2 years ago by vidrep

Attachment: screenshot2.png added

comment:10 Changed 2 years ago by vidrep

After a reboot, I opened the same file from the CLI. Attached are two more screenshots and the syslog from that session.

Changed 2 years ago by vidrep

Attachment: screenshot3.png added

Changed 2 years ago by vidrep

Attachment: screenshot4.png added

Changed 2 years ago by vidrep

Attachment: syslog added

comment:11 Changed 9 months ago by cocobean

Tested on hrev52014. This seems to work. I closed/reopened MediaPlayer and restarted my playlist. Verify on your end.

Note: See TracTickets for help on using tickets.