Opened 9 years ago

Closed 8 years ago

#4609 closed bug (invalid)

Error message at opening a pkg-file

Reported by: peterm1561 Owned by: sil2100
Priority: normal Milestone: R1
Component: Applications/PackageInstaller Version: R1/alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I tried to install gobe productive and a freshly downloaded versionof videolan client. At opening both packages I got the following message:

There seems to be a filesize mismatch in the package file. The package might be corrupted or have been modified after its creation. Do you still wish to continue.

After continuing...all works well and no other errors appeared.

Change History (5)

comment:1 Changed 9 years ago by sil2100

Status: newassigned

Actually, this error does not necessarily mean anything bad - this is usually just a warning that the package _might_ be corrupted, since the file size variable in the package (FSiz) shows a different value than the actual package file size. This of course can also simply mean a harmless error during package creation.

If the package installs correctly, I would say it's more the latter. But I will look into this ASAP - could you send me a link to the two mentioned packages?

comment:2 Changed 9 years ago by sil2100

I repeat the request - could you please send the two packages in mention? Or should I assume that this is just some invalid bug, and/or the issue has been resolved? Thanks.

comment:3 Changed 9 years ago by peterm1561

I tried to attach the offending pkg files but they are too big. I have installed a newer version of haiku and I get the same error.

These pkg file are on a -old- backup cd from the good old days. I'm not sure with which tool the cd has been written, but cd writing was not too reliable in 2000.

I tried all pkg files on the disk and some are ok, others give this error.

If I'm the only one with this error than I can only come to the conclusion that there is something wrong with the old files. this case can then be seen as closed.

regards,

Peter Menagie

comment:4 Changed 9 years ago by sil2100

Would it be possible for you to upload these packages (or at least one) somewhere and paste the link to it/them here? Or maybe one of these packages is available somewhere already?

As I said, this might just mean that the packages are faulty or maybe use some older format which results in such small incompatibilities. But it would be best for me to check that anyway.

comment:5 Changed 8 years ago by sil2100

Resolution: invalid
Status: in-progressclosed

Alright, 16 months have passed and no additional information appeared regarding this ticket. I'm therefore setting it to invalid. Might be reopened if someone notices the problem again.

Note: See TracTickets for help on using tickets.