Opened 10 years ago

Closed 10 years ago

#4616 closed bug (fixed)

notice about VirtualBox is out of date

Reported by: StephaneCharette Owned by: haiku-web
Priority: normal Milestone: R1
Component: Website/CMS Version:
Keywords: Cc: laurent.humbertclaude@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This web page is for information from 2006 and is out-of-date:

http://www.haiku-os.org/node/2546

It should be removed, as recent versions of Haiku -- including R1/alpha1 -- are working just fine in VirtualBox.

I asked about this on irc and it was suggested I open a ticket:

(09:36:22) Kokito: StephaneCharette, please file a bug report, so that the haiku-web guys become aware and possible act on it

Change History (10)

comment:1 by cb88, 10 years ago

Haiku works in Virtualbox however I'm pretty sure it requires that your computer supports hardware virtualisation or the AMD-V or Intel-VT and the support must be enabled in the preferences.

I believe Virutalbox does the by default now if your PC supports these instructions since they are greyed out for me.

in reply to:  1 comment:2 by StephaneCharette, 10 years ago

Replying to cb88:

I believe Virutalbox does the by default now if your PC supports these instructions since they are greyed out for me.

Greyed out options in the VirtualBox GUI means your system does not support it. You are right, VirtualBox does by default run with VT-x/AMD-V enabled on systems that support hardware virtualization. This wasn't the case in older versions of VirtualBox.

comment:3 by umccullough, 10 years ago

I unpublished the article mentioned above, but I am not convinced that Haiku runs perfectly in VirtualBox.

Since I have no experience with this myself, I guess I'll let someone else write it up and summarize the current state of VirtualBox compatibility.

in reply to:  3 comment:4 by koki, 10 years ago

Replying to umccullough:

I unpublished the article mentioned above, but I am not convinced that Haiku runs perfectly in VirtualBox.

The purpose of unpublishing the article is not to claim that Haiku runs perfectly (which we don't).

OK to close this ticket.

comment:5 by nielx, 10 years ago

Resolution: fixed
Status: newclosed

comment:6 by chowette, 10 years ago

Cc: laurent.humbertclaude@… added
Resolution: fixed
Status: closedreopened

I can confirm that Haiku is running fine in VirtualBox with and without VT-x/AMD-V enabled My 1st setup is :

-Host : Ubuntu amd64 running on a Core2 Duo

VirtualBox 2.2.4

-Guest : pre R1 alpha Haiku .vmdk image (haiku-pre-alpha-gcc4-hrev32662-vm.zip)

My 2nd setup is :

-Host : WinXp running on a Core2 Duo

VirtualBox 3.0.6 with SMP set to 2 Virtual Processors ( work also with 4 )

-Guest : R1 alpha Haiku .vmdk image (haiku-r1alpha1-vmdk.zip)

comment:7 by umccullough, 10 years ago

Please indicate what you feel we need to do. We have already unpublished the "outdated" article mentioned in this ticket.

comment:8 by umccullough, 10 years ago

For further clarification, besides this bug, there was a mailing list thread that took place about this particular page that occurred simultaneously. Please read here:

http://www.freelists.org/post/haiku-web/Outdated-and-misleading-Haiku-and-VirtualBox-page

comment:9 by chowette, 10 years ago

Ok, you can surely close this ticket, I have found a page that seems to be up-to-date.

http://www.haiku-os.org/documents/user/haiku_under_emulation

It surely needs a better exposure, I had hard time to find it...

If you need, I can rewrite the removed page... Sorry for the trouble .

comment:10 by mmadia, 10 years ago

Resolution: fixed
Status: reopenedclosed
Version: R1/alpha1
Note: See TracTickets for help on using tickets.