Opened 10 years ago

Closed 9 years ago

#4747 closed bug (fixed)

runtime_loader ... Could not resolve symbol 'nl_langinfo'

Reported by: scottmc Owned by: zooey
Priority: normal Milestone: R1
Component: System/POSIX Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When trying to build the latest Python on Haiku I run into this:

runtime_loader: /boot/common/lib/libpython2.6.so.1.0: Could not resolve symbol 'nl_langinfo'
resolve symbol "nl_langinfo" returned: -2147478780
runtime_loader: /boot/common/lib/libpython2.6.so.1.0: Troubles relocating: Symbol not found
make: *** [sharedmods] Error 4

Change History (9)

comment:1 Changed 10 years ago by scottmc

Turns out this doesn't just affect building python but also breaks the previously working python. This is on hrev33446, python was working on R1A1 which was hrev33109, so something between then and now broke it.

comment:2 Changed 10 years ago by axeld

Owner: changed from nobody to zooey

I guess this has been caused by the locale kit merge.

comment:3 Changed 10 years ago by zooey

Installed (well, restored) a temporary fix for this in hrev33575.

Keeping open until I find the time to work on implementing the missing functions (via ICU).

comment:4 Changed 10 years ago by kaliber

Zooey, where are you going to implement nl_types and others? In libroot.so or in liblocale.so? In the first case, libroot have to be linked against icu (bad), in the second one case a software should check for liblocale.

comment:5 in reply to:  4 Changed 10 years ago by zooey

Replying to kaliber:

Zooey, where are you going to implement nl_types and others? In libroot.so or in liblocale.so? In the first case, libroot have to be linked against icu (bad), in the second one case a software should check for liblocale.

Implementing it in libroot isn't necessarily bad, *if* the other POSIX locale stuff is implemented via ICU, too. But that has not been decided yet, and I can't tell now, because I do not know if ICU can be used to implement all the POSIX locale stuff and/or the functions declared in the three headers mentioned in this ticket. Time will tell, I guess ;-)

comment:6 Changed 9 years ago by zooey

Status: newin-progress
Version: R1/alpha1R1/Development

comment:7 Changed 9 years ago by zooey

Should be fixed by hrev37500.

Keeping this open until that rev has been merged into trunk.

comment:8 Changed 9 years ago by kaliber

It seems that this bug has been fixed.

comment:9 Changed 9 years ago by zooey

Resolution: fixed
Status: in-progressclosed

Yep, this has been fixed with the reintegration of posix-locale (hrev37725)

Note: See TracTickets for help on using tickets.