Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4760 closed bug (fixed)

Crash on query code.

Reported by: bga Owned by: axeld
Priority: high Milestone: R1
Component: File Systems/BFS Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

this seems to have been introduced by hrev33496. Whenever I try to open an email file, I am sent to KDL due to a crash in query-related code.

See attached file for stack trace.

Attachments (1)

KDL.jpg (270.6 KB ) - added by bga 10 years ago.

Download all attachments as: .zip

Change History (8)

by bga, 10 years ago

Attachment: KDL.jpg added

comment:1 by bga, 10 years ago

Component: - GeneralFile Systems/BFS
Owner: changed from nobody to axeld
Priority: normalhigh
Version: R1/alpha1R1/Development

comment:2 by axeld, 10 years ago

Status: newassigned

comment:3 by axeld, 10 years ago

Resolution: fixed
Status: assignedclosed

Should be fixed in hrev33517, please confirm.

comment:4 by bga, 10 years ago

Yep. Working ok now. Thanks.

comment:5 by axeld, 10 years ago

I still wonder why I couldn't reproduce that bug, though. The code was pretty obvious about that :-)

comment:6 by bga, 10 years ago

Do you use MDR? Could it be because I had a mail query going on (MDR's Deskbar replicant)?

comment:7 by axeld, 10 years ago

I'm using MDR, too. And besides that, every query that failed before the change should have ended up in this crash (which I tested, of course).

Note: See TracTickets for help on using tickets.