Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#477 closed bug (fixed)

listing a large directory in the Terminal brings system to a crawl

Reported by: stippi Owned by: axeld
Priority: high Milestone: R1
Component: System/Kernel Version:
Keywords: Cc: diver
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

steps to reproduce:

mountvolume YourPrimaryBeOSVolume cd /YourPrimaryBeOSVolume/home/mail/in ls -l

Their will first be much disk activity without anything being listed yet, then the contents will slowly be displayed, but the system is unresponsive already. It keeps going but everything will slow to pretty much a complete stop. I tried killing Terminal via the Team Monitor, which failed. The Team Monitor just went away, then the mouse cursor wouldn't move anymore, but I could still see the clock updating in Deskbar. Then I purposfully entered KDL (which relaxed the CPU fan) and rebooted the system from there.

100% reproducable. I have 1850 mails in that folder.

Change History (7)

comment:1 by diver, 13 years ago

Cc: diver added

comment:2 by marcusoverhagen, 13 years ago

dependson: 80

comment:3 by axeld, 13 years ago

Can you still reproduce this? It should be fixed with hrev17479.

comment:4 by stippi, 13 years ago

No, unfortunately I can still reproduce it. Listing my mailsfrom the app_server list goes on for a little bit, thensuddenly the Terminal output stops. The system will be sluggish,but not at all as bad as when I originally reported the bug.When I tried to kill Terminal using the Team Monitor, theDeskbar entry disappeared, but the window stayed on screen. Irebooted the system from the Deskbar, Tracker windows wereslowly closing, the process didn't halt at the Terminal,probably because Terminal was not on the rosters list ofrunning apps.We probably nail this one during BeGeistert, when you have mymachine in front of you... :-)

comment:5 by axeld, 13 years ago

Sorry, couldn't wait, fixed in hrev17490 :)

comment:6 by axeld, 13 years ago

Resolution: fixed

comment:7 by axeld, 13 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.