Opened 13 years ago

Closed 11 years ago

#478 closed bug (fixed)

[Deskbar] crash if you drop some selected text on it

Reported by: diver Owned by: mmlr
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by jackburton)

Steps to reproduce: Open AboutHaiku and click hall of fame BTextView, press alt+a to select text. Now grag it with right mouse button above deskbar and drop it on any folder (Application/Preferences) Deskbar will crash.

Tested with rev17117 under vmware.

Attachments (3)

deskbar.PNG (31.5 KB) - added by diver 13 years ago.
back trace
back trace.png (65.6 KB) - added by diver 12 years ago.
new back trace
Deskbar_crash.png (66.2 KB) - added by diver 12 years ago.
Yet another back trace

Download all attachments as: .zip

Change History (20)

comment:1 Changed 13 years ago by mmlr

Owner: changed from axeld to mmlr

comment:2 Changed 13 years ago by mmlr

Seems to be a BMessage problem. Will look into it.

Changed 13 years ago by diver

Attachment: deskbar.PNG added

back trace

comment:3 Changed 13 years ago by jackburton

Works here, probably fixed in the meantime

comment:4 Changed 13 years ago by jackburton

Resolution: worksforme

comment:5 Changed 13 years ago by jackburton

Status: newclosed

comment:6 Changed 13 years ago by diver

It's still here in hrev17653, reopening. Michael, could you have a look?

comment:7 Changed 13 years ago by diver

Resolution: worksforme

comment:8 Changed 13 years ago by diver

Status: closedreopened

Changed 12 years ago by diver

Attachment: back trace.png added

new back trace

Changed 12 years ago by diver

Attachment: Deskbar_crash.png added

Yet another back trace

comment:9 Changed 11 years ago by diver

Platform: All

Still here in hrev22867.

comment:10 Changed 11 years ago by humdinger

Can't reproduce in vmware hrev22979. @diver: maybe you could retry with updated image.

comment:11 Changed 11 years ago by aldeck

Can't reproduce the crash with hrev23705 / vmware.

However drag'n'droping things seems to trigger #582 under certain circumstances.

Diver, can you confirm? Otherwise i'll close this one and post an update in #582

comment:12 Changed 11 years ago by diver

Component: - GeneralKits/Interface Kit

Yes, i can confirm it, I just dropped text on Application folder in Leaf Menu and it crashed with bt like in Deskbar_crash.png. So the bug (which according to different back traces could be even more) is still there.

comment:13 Changed 11 years ago by aldeck

Ok, sorry, i misunderstood your initial steps. I was dropping on the leaf menu :-/ I can reproduce, and got one of the two same backtraces, but only if i pass over an item in the team menu (ex: tracker). Same conditions as in my comment in #582.

I tested drag'n'dropping a text file, and if i roll over the tracker item before going deeper into the leaf menu, i still get the crash, but the file gets opened in styledit, as if i had dropped it on the tracker item. It seems like a message (release/drop) goes to the wrong person :)

comment:14 Changed 11 years ago by aldeck

Oh, and i must add, the original bug doesn't appear when Deskbar is in horizontal mode.

In horizontal mode, we can see that the menuitems react differently to hovering:

Move over the Tracker menuitem while grabbing a text file. Leave the item by the top (so it remains selected), and then drop the file on the desktop. -> The the file gets opened in StyledEdit.

I hope i'm clear :)

comment:15 Changed 11 years ago by kaoutsis

i can't reproduce here, hrev25184

comment:16 in reply to:  15 Changed 11 years ago by aldeck

Replying to kaoutsis:

i can't reproduce here, hrev25184

Still 100% reproducible here on hrev25761. The ticket title is a bit misleading: you must drop it on a submenu of the leaf menu, not the leaf menu itself. And also, it only happens if you pass over an item in the deskbar's app/team menu. The hovered item stays selected even if your mouse has moved from it, and it seems that it gets the drop message too.

comment:17 Changed 11 years ago by jackburton

Description: modified (diff)
Resolution: fixed
Status: reopenedclosed

This was also fixed in hrev28063 by Oliver and Stephan.

Note: See TracTickets for help on using tickets.