Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4776 closed bug (invalid)

VNC server and use of remote clipboard paste size bug limit to 63.9 Kilobytes of text.

Reported by: Super Dave Osbourne Owned by: nobody
Priority: normal Milestone: R1
Component: Servers Version: R1/alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by mmlr)

Have verified with tests driving Pe and Styled Edit that getting data/text larger than 63.9 K i size from the clipboard to a application as well as from and onto the clipboard is the size limit regardless of various larger than 63.9 K copy and paste attempts. The VNC server should be able to get whatever sized data is on the system clipboard, and also provide that same data to a remote VNC client.

1.  Install and run the server of VNC for haiku, only the server.
2.  Install and run a VNC client on your host.
3.  Make a connection to the Haiku VM VNC server.
4.  On local host open 1.5 meg file and copy all the text.
5.  In connection window to the VM VNC server, open the Pe or StyledEdit apps.
6.  In either app opened in #5, paste.
7.  Witness the size limit, about 63.9K of text is pasted.

Please fix this bug, it hampers remote boundary testing that I'm doing.

Attachments (1)

Archive.zip (6.4 KB) - added by Super Dave Osbourne 10 years ago.
a zip archive of a 1.6 meg and the limited size of paste file which is about 63.9K

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by Super Dave Osbourne

Attachment: Archive.zip added

a zip archive of a 1.6 meg and the limited size of paste file which is about 63.9K

comment:1 in reply to:  description Changed 10 years ago by mmlr

Description: modified (diff)
Resolution: invalid
Status: newclosed

Replying to Super Dave Osbourne:

The VNC server should be able to get whatever sized data is on the system clipboard, and also provide that same data to a remote VNC client.

Whatever VNC server you installed, it is not a part of Haiku. You should report the bug to either the VNC server or client developer, as the limit is imposed somewhere there. At least there is no such limit to be reproduced on a normal system.

Please fix this bug, it hampers remote boundary testing that I'm doing.

Please drop this demanding attitude. Most bugs hamper with someones plans or work, that doesn't mean that there's anyone owing anyone else a bugfix because of that. I certainly admire the efforts you put into the testing automation, but this attitude just comes off pretty rude.

comment:2 Changed 10 years ago by axeld

We still have this 64K port message size restriction. It could be related to that, depending on how this VNC support is implemented.

Note: See TracTickets for help on using tickets.