Opened 10 years ago

Closed 10 years ago

#4780 closed bug (duplicate)

Tracker crashes, or locks up, or becomes disfunctional

Reported by: Super Dave Osbourne Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/alpha1
Keywords: Cc:
Blocked By: #4778 Blocking:
Has a Patch: no Platform: All

Description

Create a full 4 gig disk (may not be related) with 1 meg files, and get info for them all. Loads of windows, and the first time Tracker crashed, went away. Second time I video'd and the Tracker just became unquitable, unresponsive. Had to reboot. Likely just too many threads?

Change History (2)

comment:1 Changed 10 years ago by Super Dave Osbourne

Here is a video of the second attempt to get 4000+ info box windows open in a VMWare Alpha RC 1 on OS X 10.6.1, video grabbed with my testing tool via VNC.

http://www.vimeo.com/7051042

No commentary in the video, here is the Vimeo comment:

Many files, about 4000+ were created to fill test a volume, and then to follow up with a test of Get Info (load test for threading) on Tracker. Showing the files in Tracker, of the volume in question, I then 'get info' for the 4000+ files, a bunch of info windows start to show up, and then Tracker crashed after a bit. I then recorded the same scenario, with slightly different results, Tracker locking up pretty good, and finally when I closed all the info windows with (cntrl-w), Tracker and the system became unresponsive and had to power down the VM to get things working again.

comment:2 Changed 10 years ago by axeld

Blocked By: 4778 added
Resolution: duplicate
Status: newclosed

It's possible that this is a duplicate of #4778, at least the outcome is pretty much the same. I'll mark it as a duplicate for now; when #4778 is fixed, and you can still reproduce it, please open it again.

Note: See TracTickets for help on using tickets.