Opened 9 years ago

Closed 5 years ago

#4781 closed bug (invalid)

looks like haiku detects audio but will not play it ICH3

Reported by: togermano Owned by: korli
Priority: normal Milestone: R1
Component: Drivers/Audio/auich Version: R1/alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Hello I installed haiku on a ibm thinkpad t23 laptop, Everything seems to be running fine except for the audio. Windows catergorizes the soundcard as a crystal soundcard while haiku says its an ac97 which I think linux also did which worked fine. I think I remember seeing references to ac97 in the windows audio driver .inf file. Anyways here is this the problem I open up any mp3 or video file with the built in media player music will not play. I went to the media prefs to uncheck all the mutes and this still did not fix anything. When I press play on an mp3 file the status bar does not move at all to show its playing. I also tried using cl mp3 player the winamp clone it did the same exact thing. Another weird thing is that if I unchecked mute microphone in media prefs haiku will broadcast the noises from the mic to my laptop speakers no problem so i guess it means the audio driver works okay? or somewhat okay... If you guys need any more info tell me what I need to do and i'll post back with that info

Change History (6)

comment:1 Changed 9 years ago by togermano

here is a listdev report

device Multimedia controller (Multimedia audio controller) [4|1|0]
  vendor 8086: Intel Corporation
  device 2485: 82801CA/CAM AC'97 Audio Controller
Last edited 8 years ago by diver (previous) (diff)

comment:2 Changed 9 years ago by mmadia

Component: Audio & VideoDrivers/Audio
Owner: changed from nobody to korli

comment:3 Changed 9 years ago by korli

Could you please try with a current revision and provide a syslog ? Thanks

comment:4 Changed 8 years ago by diver

Component: Drivers/AudioDrivers/Audio/AUICH

comment:5 Changed 8 years ago by diver

Summary: looks like haiku detects audio but will not play itlooks like haiku detects audio but will not play it ICH3

comment:6 Changed 5 years ago by korli

Resolution: invalid
Status: newclosed

Closing for lack of feedback.

Note: See TracTickets for help on using tickets.