Opened 10 years ago

Closed 10 years ago

#4822 closed bug (fixed)

BTextView::LineWidth doesn't take tabs into account

Reported by: augiedoggie Owned by: zooey
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/alpha1
Keywords: Cc:
Blocked By: Blocking: #4823, #4824
Has a Patch: no Platform: All

Description

When requesting the width of a line of text it seems that BTextView does not take into account the TabWidth settings. The bebook says LineWidth should include tabs and spaces, but, it's not clear if that is after it expands the tabs to spaces.

Change History (5)

comment:1 by axeld, 10 years ago

Blocking: 4824 added

(In #4824) Duplicate of #4822 - just give Trac its time; its speed will hopefully improve when we've migrated it to the new server :-)

comment:2 by axeld, 10 years ago

Blocking: 4823 added

(In #4823) Duplicate of #4822. BTW if you see that "Get ... failed" error - it only means the reply failed (in time), not that the request hasn't been fulfilled.

comment:3 by axeld, 10 years ago

Owner: changed from axeld to zooey

Let's continue the BTextView bug fix marathon.

comment:4 by zooey, 10 years ago

Status: newassigned

comment:5 by zooey, 10 years ago

Resolution: fixed
Status: assignedclosed

Should be fixed in hrev33713.

Note: See TracTickets for help on using tickets.