Opened 10 years ago

Closed 10 years ago

#4833 closed bug (duplicate)

Flawed Desktop Volume Renaming

Reported by: Super Dave Osbourne Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/alpha1
Keywords: Cc:
Blocked By: #2149, #4223 Blocking:
Has a Patch: no Platform: x86

Description

Volumes are renamed via the Info Panels, have not tried this test with volume renaming from the Desktop. This shows volumes of 1, 2 and 4 gig sizing renamed to 2, 4 and 8 gig pig. You can see the fault of updating the desktop occurs but the volumes are properly renamed and show it after unmount, also when rebooted.

I have video of this occuring here

http://www.vimeo.com/7209925

Running VMWare Fusion for OS X, with Haiku R1/Alpha on Mac Book Pro 17" unibody.

~> sysinfo Kernel name: kernel_x86 built on: Sep 12 2009 17:45:45 version 0x1 1 Intel Core 2 Extreme, revision 467a running at 2784MHz (ID: 0x00000000 0x00000000)

CPU #0: "Intel(R) Core(TM)2 Duo CPU T9600 @ 2.80GHz"

Type 0, family 6, model 23, stepping 10, features 0x0febfbff

FPU VME DE PSE TSC MSR PAE MCE CX8 APIC SEP MTRR PGE MCA CMOV PAT PSE36 CFLUSH DS ACPI MMX FXSTR SSE SSE2 SS

Extended Intel: 0x80082201

SSE3 CMPXCHG16B

Extended AMD: type 0, family 0, model 0, stepping 0, features 0x20100000

NX 64

Power Management Features:

L2 Data cache 8-way set associative, 1 lines/tag, 64 bytes/line L2 cache: 6144 KB, 16-way set associative, 0 lines/tag, 64 bytes/line

Inst TLB: 2M-bytes pages, 4-way set associative, 8 entries OR 4M, 4-way, 4 entries Inst TLB: 4K-bytes pages, 4-way set associative, 128 entries Data TLB: 4M-byte pages, 4-way set associative, 32 entries 64-byte Prefetching L1 Data TLB: 4K-bytes pages, 4-way set associative, 16 entries L1 Data TLB: 4M-bytes pages, 4-way set associative, 16 entries L2 cache: 6144 KB, 24-way set associative, 64 bytes/line L1 inst cache: 32 KB, 8-way set associative, 64 bytes/line Data TLB: 4K-bytes pages, 4-way set associative, 256 entries L1 data cache: 32 KB, 8-way set associative, 64 bytes/line

962244608 bytes free (used/max 111497216 / 1073741824)

(cached 33177600)

129746 semaphores free (used/max 1326 / 131072)

3965 ports free (used/max 131 / 4096) 3979 threads free (used/max 117 / 4096) 2030 teams free (used/max 18 / 2048)

Change History (4)

comment:1 by Super Dave Osbourne, 10 years ago

Does seem to correct itself when you restart the Tracker application.

comment:2 by Super Dave Osbourne, 10 years ago

Component: ApplicationsApplications/Tracker
Owner: changed from nobody to axeld
Platform: x64x86

Tracker completely locks up if you repeat this test 3-4 times, no response, must reset machine. Video included on this 4th renaming try (3 previous videos show the above mentioned naming problems as well):

http://www.vimeo.com/7214018

This is repeatable with my automation scripting:

http://pastie.org/666212

comment:3 by scottmc, 10 years ago

This sounds like a dupe of #2149.

comment:4 by axeld, 10 years ago

Blocked By: 2149, 4223 added
Resolution: duplicate
Status: newclosed

The hang is probably a duplicate of #4223. Please alway only mention one bug per ticket.

Note: See TracTickets for help on using tickets.