Opened 10 years ago

Closed 9 years ago

#4878 closed bug (fixed)

App "Screenshot" always capture tracker after choosing "capture active window"

Reported by: streak Owned by: julun
Priority: normal Milestone: R1
Component: Applications/Screenshot Version: R1/alpha2
Keywords: Cc: WPJvanderMeer@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

App "Screenshot" always capture tracker window after choosing "capture active window" no matter what active window will be.

Change History (9)

comment:1 Changed 10 years ago by humdinger

I can't reproduce here. Have you set a delay? Do you use the button "Take Screenshot" from the options panel? Do you use another Mouse focus mode than "Click to Activate"?

I think you'll have to provide more info, best a step-by-step procedure.

comment:2 Changed 9 years ago by Wim

This is probably a duplicate of #3112, but without more information it is hard to tell for sure.

Since this bug report is already 6 months old, I don't think we can expect more information from the original reporter.

I have proposed to close #3112 as invalid, and for the same reason I also propose to close this bug as invalid.

comment:3 Changed 9 years ago by streak

i'll try to check it today on more recent build ...

comment:4 Changed 9 years ago by nielx

Has a Patch: unset

TEST: please ignore

comment:5 in reply to:  3 Changed 9 years ago by Wim

Cc: WPJvanderMeer@… added

Replying to streak:

i'll try to check it today on more recent build ...

Are you able to reproduce the problem?

comment:6 Changed 9 years ago by streak

Version: R1/alpha1R1/alpha2

Checked on A2

This time application always captures "deskbar" instead of tracker no matter what app has been chosen for capturing.

comment:7 Changed 9 years ago by humdinger

It does display the behaviour you describe only if "Always on top" is checked in the Deskbar prefs. Even setting a delay of some seconds in which you activate your target window will still shoot the Deskbar.

comment:8 in reply to:  7 Changed 9 years ago by Wim

Replying to humdinger:

It does display the behaviour you describe only if "Always on top" is checked in the Deskbar prefs. Even setting a delay of some seconds in which you activate your target window will still shoot the Deskbar.

OK, I can confirm this. Currently the application finds the "active" window by looking for the window that is on top, and assuming that that is the active window.

I am now in the process of basically rewriting the app, I will make sure it behaves correctly when I finish it.

comment:9 Changed 9 years ago by Wim

Resolution: fixed
Status: newclosed

Fixed in hrev37017.

Note: See TracTickets for help on using tickets.