Opened 10 years ago

Closed 5 years ago

#4879 closed bug (fixed)

Expander cant handle password protected archives.

Reported by: streak Owned by: korli
Priority: normal Milestone: R1
Component: Applications/Expander Version: R1/alpha1
Keywords: gci2011 Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Expander cant handle password protected archives [ rar / 7z ]. It just freezes on password protected archives.

Attachments (5)

zip.zip (159 bytes ) - added by luroh 9 years ago.
rar.rar (95 bytes ) - added by luroh 9 years ago.
7z.7z (143 bytes ) - added by luroh 9 years ago.
password for the archives is: asdf
zip-2.zip (201 bytes ) - added by luroh 9 years ago.
Zip 3.0, Linux
rar-2.rar (97 bytes ) - added by luroh 9 years ago.
WinRAR 3.93, WinXP

Download all attachments as: .zip

Change History (23)

comment:1 by korli, 9 years ago

Added handling in hrev38876. Tested with zip archives only. Please check.

comment:2 by luroh, 9 years ago

hrev38885, gcc2, VMware. Although none of them cause any freeze, I'm unable to extract password protected zip, rar and 7z files using Expander. Attaching my test files for convenience, the password is 'asdf'.

by luroh, 9 years ago

Attachment: zip.zip added

by luroh, 9 years ago

Attachment: rar.rar added

by luroh, 9 years ago

Attachment: 7z.7z added

password for the archives is: asdf

comment:3 by korli, 9 years ago

On Linux, zip.zip gives this message: skipping: zip.txt unsupported compression method 99

On Haiku, unrar seems unhappy with the password asdf, not related to Expander (I checked the md5sum)

7z.7z works for me with Expander.

comment:4 by luroh, 9 years ago

Strange, I can download and extract all three files on Linux (Ubuntu 10.04) and Windows (Win7 + WinRAR) but none of them extracts successfully in Haiku (gcc2).

in reply to:  4 comment:5 by korli, 9 years ago

Replying to luroh:

Strange, I can download and extract all three files on Linux (Ubuntu 10.04) and Windows (Win7 + WinRAR) but none of them extracts successfully in Haiku (gcc2).

I trust you :) Please check then with command line compression tools on Haiku.

On Linux, I checked with "UnZip 5.52 of 28 February 2005". What are the tools you use on Linux?

comment:6 by luroh, 9 years ago

I have tried Expander and all command line tools I could find in Haiku gcc2 without being able to decompress any of the files. Any pointers how to decompress the 7z file successfully from Terminal?

On Linux, 7-Zip 9.04 beta takes care of the zip and 7z files, UNRAR 3.90 beta 2 (non-free) is needed for the rar file.

comment:7 by korli, 9 years ago

We might need to update unzip to 6.0 and unrar to 3.9.10. The latter might be externalized as an optional package as I don't think we change anything.

comment:8 by luroh, 9 years ago

I have "UnZip 6.00 of 20 April 2009, by Debian" installed on my Ubuntu system as well, and that version produces the same error for the zip file like you saw in 5.52, 'unsupported compression method 99'.

comment:9 by luroh, 9 years ago

To be fair, a vanilla Ubuntu install (I just checked Ubuntu 10.10 beta) can't decompress any of the files either (both 7-Zip and UNRAR have been added manually by me at some point) and Windows can only deal with the zip file out of the box.

comment:10 by korli, 9 years ago

Then you should better use compatible test files to actually verify this bug.

comment:11 by luroh, 9 years ago

Indeed, 7-Zip may be responsible for creating nasty zip files, I am uploading a new one created using Zip 3.0 under Linux, it decompresses fine in Haiku. A friend created the rar file for me using WinRAR 3.91 beta 1 under Windows XP, I am uploading a new one created using WinXP + WinRAR 3.93, it however still doesn't decompress in Haiku (as you've stated already, we may need a newer version of unrar). As for 7z, I have no idea how to create a more compatible test file.

by luroh, 9 years ago

Attachment: zip-2.zip added

Zip 3.0, Linux

by luroh, 9 years ago

Attachment: rar-2.rar added

WinRAR 3.93, WinXP

comment:12 by korli, 9 years ago

Haiku includes a command line tool:

7za a 7z-2.7z 7z.txt -pasdf

comment:13 by luroh, 9 years ago

Ah, thanks, turns out it isn't included in the bare-bones image by default. I added the optional package P7zip and now the 7z.7z file works as well.

comment:14 by Bth8, 8 years ago

I had no trouble expanding the passworded zip, but I can't expand the passworded RAR. It creates a listing just fine and then prompts me for a password, but after I enter the password, it just closes. No files are extracted.

comment:15 by umccullough, 8 years ago

Keywords: gci2011 added

in reply to:  14 comment:16 by siarzhuk, 7 years ago

Replying to Bth8:

I had no trouble expanding the passworded zip, but I can't expand the passworded RAR. It creates a listing just fine and then prompts me for a password, but after I enter the password, it just closes. No files are extracted.

That means that extraction was failed because CRC errors. Default behaviour of unrar in this case - delete extracted files.

comment:17 by siarzhuk, 7 years ago

Please check with hrev45188. unrar was updated to version 4.2.4 and password handling should be functional now. Note that UnRAR was outsorced to optional package and you have to install UnRAR package before check. Please be sure that old 3.7.8 version is removed from your /boot/system/bin folder.

PS: I have observed some problems with archives protected with non-latin (cyrillic for example) passwords. But such problems are observed with this archives on other OSes too. ;-)

comment:18 by pulkomandy, 5 years ago

Resolution: fixed
Status: newclosed

Confirmed working with the above test files.

Note: See TracTickets for help on using tickets.