Opened 9 years ago

Closed 4 months ago

#4895 closed bug (invalid)

Git get stucked on fifo::Inode::ReadDataFromBuffer

Reported by: emitrax Owned by: nobody
Priority: high Milestone: R1
Component: System/Kernel Version: R1/alpha1
Keywords: Cc: planche2k@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I was trying to check out Webkit source from Haiku running in vmware directly on a USB stick BFS formatted.

Git got stuck and I've not idea why. The stack trace is attached.

Since the program is waiting on a fifo file, don't know what is used for, how should I found out who is the writer on the other side?

I could not find any fifo related KDL command.

Attachments (1)

git backtrace.png (33.2 KB) - added by emitrax 9 years ago.
Git stack trace

Download all attachments as: .zip

Change History (9)

Changed 9 years ago by emitrax

Attachment: git backtrace.png added

Git stack trace

comment:1 Changed 9 years ago by axeld

Component: File SystemsSystem/Kernel
Owner: changed from nobody to axeld

That probably just means that no data arrived. It's just the question why, but this could have any reason. Switching to a more likely component.

Is this problem reproducible?

comment:2 Changed 9 years ago by emitrax

I tried it only once at work. I'll see if I can try it again tomorrow.

Any suggestion or other info I should gather that might be useful?

comment:3 in reply to:  2 Changed 9 years ago by bonefish

This might not even be a kernel problem at all.

Replying to emitrax:

I tried it only once at work. I'll see if I can try it again tomorrow.

Any suggestion or other info I should gather that might be useful?

I would expect the fifo to be a pipe to a child process (maybe a transport tunnel like ssh), so the problem is probably just that the writer doesn't write anything for any reason. Finding out who is the writer and why it isn't doing anything would get us further. A look at the git sources to understand what is supposed to happen at this point might also help.

comment:4 Changed 9 years ago by emitrax

Ok, I tried again this morning from work and the directory got deleted. CPU activity was bit higher, 35% at most, but was going up and down. Personally I would expect something a lot higher to get thing faster. Looks like my slow laptop (1.6Ghz) brings out a lot of issues.

Now I'm trying to check out again the source.

PS. I just noticed "block notifer/writer" KDL'ed. I'll open a different bug. PSS. Would it be possible to write some KDL command to get more info about the pipe ?

comment:5 Changed 9 years ago by andreasf

Cc: planche2k@… added

comment:6 Changed 6 years ago by scottmc

Have you run into this issue recently? Perhaps try it on R1Alpha4.1 on that same hardware if you still have it and see if this still happens. There's been a few revisions to haiku and to git since this first happened.

comment:7 Changed 20 months ago by axeld

Owner: changed from axeld to nobody
Status: newassigned

comment:8 Changed 4 months ago by waddlesplash

Resolution: invalid
Status: assignedclosed

No reply in 6 years.

Note: See TracTickets for help on using tickets.