Opened 9 years ago

Closed 9 years ago

#4896 closed bug (fixed)

vm_page_fault in thread ipro1000 consumer

Reported by: Adek336 Owned by: zooey
Priority: critical Milestone: R1
Component: Network & Internet/IPv4 Version: R1/alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Happened after starting netcat as client. Alpha, in vmware.

Attachments (3)

32.png (72.0 KB) - added by Adek336 9 years ago.
21.png (10.3 KB) - added by Adek336 9 years ago.
ipv4.diff (721 bytes) - added by zooey 9 years ago.
proposed patch that should fix the cause in the fragment reassembling code

Download all attachments as: .zip

Change History (10)

Changed 9 years ago by Adek336

Attachment: 32.png added

comment:1 Changed 9 years ago by axeld

Component: - GeneralNetwork & Internet/IPv4
Owner: changed from nobody to zooey
Priority: normalcritical

comment:2 Changed 9 years ago by Adek336

I have a virtual machine snapshot of the kdl so I can use kdl commands in that state.

comment:3 Changed 9 years ago by axeld

Is it a GCC4 or GCC2 build? In any case, a disassembly of the frame in question would be helpful ("dis -b 10").

Since there was no "net_buffer" command in your version (I just added it in hrev33893), you could use "dw 0x841fdff8 32" to dump the buffer itself.

Changed 9 years ago by Adek336

Attachment: 21.png added

comment:4 Changed 9 years ago by Adek336

This is the Alpha build of Haiku.

Changed 9 years ago by zooey

Attachment: ipv4.diff added

proposed patch that should fix the cause in the fragment reassembling code

comment:5 Changed 9 years ago by zooey

Status: newassigned

comment:6 Changed 9 years ago by zooey

I have added a patch that should fix the crash - Axel, could you please review the patch?

comment:7 Changed 9 years ago by axeld

Resolution: fixed
Status: assignedclosed

The patch was not correct, as it changed the order in which the packets were inserted to the list (Insert(a, b) inserts 'b' before 'a'). Thanks for the quick patch, zooey - I didn't even remember you were the component owner :-)

Fixed in hrev33908.

Note: See TracTickets for help on using tickets.