Opened 10 years ago

Closed 10 years ago

#4944 closed bug (invalid)

RAW converted to VDI boots in Virtualbox - VMDK does no longer

Reported by: luroh Owned by: nobody
Priority: normal Milestone: R1
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

gcc2, rev 34013, Virtualbox 3.0.10.

Our .vmdk file no longer works in Virtualbox. It immediately fails with the following error, without showing any boot splash:

FATAL: No bootable medium found! System halted.

However, converting our raw .image file to a .vdi file makes Haiku boot fine. The command used for converting the image was:

VBoxManage convertfromraw -format VDI haiku.image haiku.vdi


I am not sure whether this is due to changes in Virtualbox, a regression in Haiku, some old Haiku bug triggered by the new version of Virtualbox, or something else entirely. Suggestions for further testing welcome.

Change History (3)

comment:1 by luroh, 10 years ago

Possibly related issue, I can't tell: http://www.virtualbox.org/ticket/5355
If it makes sense, I'll install another Linux box and try switching between Virtualbox 3.0.10 and 3.0.8 as suggested in that ticket.

comment:2 by diver, 10 years ago

It seems it was a regression, VirtualBox 3.0.12 is able to boot haiku .vmdk again.

comment:3 by jackburton, 10 years ago

Resolution: invalid
Status: newclosed

Since it is/was a VirtualBox bug, let's close this.

Note: See TracTickets for help on using tickets.